Proxmox VM- Xorg Server failed to start

  • I am trying to get LibreELEC working on Proxmox. I had download LibreELEC-Generic.x86_64-10.0.1.ova upload it to Proxmox unpacked and created Virtual Machine with 2 disks -one for instalation media and second as system disk. I had start it, installed it on virtual sata disk and it booted up for first time. After couple seconds I always get the warning says "Xorg Server failed to start is your GPU supported?". I tried to passtrough igpu to it but I get bootloops. How can I get it to work if I dont have any GPU (I just use Proxmox noVNC window)

  • You can't path through your igpu because the gpu is blocked/used from your base system :)

    Pls make sure you have at least proxmox 7 or 7.1, there were a lot fixes for the VMs.

    At least the software rendering should work. The VNC works at VM level so has nothing todo with the OS (I guess).


    You can try to change the PC type to q35 or i440fx.

  • I got Proxmox 7.1-5. Tried with both q35 and 440fx but nothing changed- still Xorg Server error.