Something causing my TV to turn on by itself

  • After watching the kodi logs and turning the TV off and allowing it to turn back on, I finally determined that this is the moment that the TV turns on.


    Hopefully someone can figure why and resolve this for me.


    Thank you.


    Daryl

  • It seems like the Kodi screensaver activates the TV over CEC.


    Test these workarounds:

    • Deactivate the Kodi screensaver.
    • Go into LE's input device settings, select "CEC Adapter", and make the RPi always send A/V signal over HDMI (and/or disable all TV wake-up calls).

    DNB music-addicted finger drummer.

  • It seems like the Kodi screensaver activates the TV over CEC.


    Test these workarounds:

    • Deactivate the Kodi screensaver.
    • Go into LE's input device settings, select "CEC Adapter", and make the RPi always send A/V signal over HDMI (and/or disable all TV wake-up calls).


    I don't see anything about sending A/V signals over HDMI. And all of the wake-up calls have been disabled, as a matter of fact, that is one of the first things taht I do when setting up a PI for this particular TV. When I first started using kodi years ago, this was an issue and I figured out that I needed to disable all wake-up calls to prevent this from happening.


    I also thought that it was the screensaver and disabled it as well, but the TV still turns on.


    Any additional thoughts?


    Daryl


    I disabled the screensaver and tested again. This time (and I've seen this before) I get a similar error when LE queries my local PVR.



    I've seen this before, and disabled the PVR, but the TV still turned on. However, I've never disabled the screensaver and PVR at the same time. I'll try that and see what happens.


    Daryl

    Edited once, last by rosede: Merged a post created by rosede into this post. ().

  • With both PVR and screensaver disabled, this is what I get when the LE turns on the TV



    The only constant is

    Quote

    2022-01-04 09:28:47.664 T:829 DEBUG <general>: SetConfigurationFromLibCEC - settings updated by libCEC

    This seems to be the issue. At this moment, the only options that I have are to shut down the Pi when turning off the TV, or disable CEC, which defeats the purpose of having CEC.


    This seems to be an issue with LE. Please take a look at this and resolve.


    Thank you.


    Daryl

  • I had this problem in earlier versions and have used these settings with my RPI4 and Samsung TV. TV has not randomly turned on since installing 10.1. The only addon I'm using is the Zuki PVR. I always leave the Pi4 on.


    Set menu to advanced


    Settings > System 1920x1080 60Hz

    LibreELEC Add-On PVR/Live TV > General> Use channel numbers from backend


    Settings > System > Input > Peripherals > CEC > Switch source to this device on startup > "Set to off"

    Settings > System > Input > Peripherals > CEC > Devices to power on during startup > "None"

    Settings > System > Input > Peripherals > CEC > Devices to power off during shutdown > "None"

    Settings > System > Input > Peripherals > CEC > "when the TV is turned off" > "Stop playback"

    Settings > System > Input > Peripherals > CEC > "switch source to this device on startup" from "on" to "off


    Settings > Interface > Regional > US > TZ


  • Yes, that is how I have my Pi setup. This is how I set it up when I first build a new PI.


    I always disable everything in CEC with the exception of keeping CEC enabled. Everything else gets disabled, or set to stop, or stop playback etc.. Identical to how you show.


    This just started when I upgraded to v10.0.0.1. All was working fine prior to the upgrade, so this tells me that the upgrade broke something and LE needs to fix it.


    Thank you.


    Daryl

  • This issue is with this line right here.

    Quote

    2022-01-04 09:28:47.664 T:829 DEBUG <general>: SetConfigurationFromLibCEC - settings updated by libCEC

    Whenever it runs, is when my TV turns on.


    Daryl

  • I don't see anything about sending A/V signals over HDMI.

    • go to Settings -> System -> Input -> Peripherals -> CEC Adapter
    • disable "Put devices in standby mode when activating screensaver"
    • disable "Wake devices when deactivating the screensaver"
    • set "When the TV is switched off" to "Ignore"
    • set "Action when switching to another source" to "None"

    DNB music-addicted finger drummer.

    • go to Settings -> System -> Input -> Peripherals -> CEC Adapter
    • disable "Put devices in standby mode when activating screensaver"
    • disable "Wake devices when deactivating the screensaver"
    • set "When the TV is switched off" to "Ignore"
    • set "Action when switching to another source" to "None"


    As I've stated several times in this post, these are the settings that I change as soon as I build a new PI.


    Just to verify that there wasn't anything else on the PI that can be causing this, or perhaps the update mucked something up, I rebuilt this PI from scratch with a fresh download of LibreELEC-RPi4.arm-10.0.1. So far all I've done is make the above changes in CEC and set the region/time information. The skin is default. Nothing else installed etc.....


    After rebuilding, I tested, and I am seeing the exact same thing. The only way to stop this, is to turn off CEC, which as I stated earlier, defeats the purpose of having CEC.


    This is an issue with CEC in this build. Please look into it.


    Thank you.


    Daryl

  • Right, this could be a bug. Before I'll ping the dev's, please provide another log, because your first log is at log level 0.

    Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem.

    Full logs only. No modified logs.

    Do not post your logs directly into the forum,
    use Settings > LE Settings Addon > System > Paste system logs
    and post the link.

    DNB music-addicted finger drummer.

  • Right, this could be a bug. Before I'll ping the dev's, please provide another log, because your first log is at log level 0.

    Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem.

    Full logs only. No modified logs.

    Do not post your logs directly into the forum,
    use Settings > LE Settings Addon > System > Paste system logs
    and post the link.

    As requested. The log is at pastebin.com


    »¿2022-01-04 15:05:11.520 T:966 INFO <general>: --------------------------- - Pastebin.com
    Pastebin.com is the number one paste tool since 2002. Pastebin is a website where you can store text online for a set period of time.
    pastebin.com


    Daryl

  • How can I roll back to v10.0.0? I don't see that as an option in Downloads?

    • login by SSH
    • cd /storage/.update
    • wget https://releases.libreelec.tv/LibreELEC-RPi4.arm-10.0.0.img.gz
    • reboot

    DNB music-addicted finger drummer.