Posts by Pretoriano

    Yes,that was for reference ,you can play it on your TV and you will notice the judder (unless you crank up de-judder to the max).


    However ,i managed to force the tv's hdmi port in "hometheater" mode (that's how LG calls it) with the help of bscpylgtv and now all the motion interpolation settings are available .

    Yep ,it's enabled and i always used it.

    For the most part it's smooth for me too ,but slow panning shots ,especially where there's more contrast between various object in the scene (eg. panning on bright windows ) ,are sometimes unbearable without motion interpolation.


    Fir example the desert/mountain scene from this video ->

    External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    And according to some infos I've found on avsforum,it seems that the oled panel's internal refresh rate is not really in sync,even if the hdmi debug info report the correct refresh rate (in our case,24hz in case of a 24p movie).


    https://www.avsforum.com/threads/2022-lg-c2-g2-owners-thread-no-price-talk.3250717/post-62197916


    https://www.avsforum.com/threa…alk.3250717/post-62198740 <-- last quote is related to kodi.

    Hi guys,a few months ago i bought a new tv,an LG G2 OLED ,hooked my RPi4 to it and everything seems to work just fine ,but the RPi4 is recognized as PC so the TV activated PC MODE automatically .


    The problem is that when the TV is in PC MODE,all the motion settings (Real Cinema and TruMotion settings on LG G2 ) are disabled si i'm getting a lot of judder when watching movies (24p movies).


    Is there a way to force the RPi4 as a media player (or whatever it's called ) ,so i can get the motion settings back?


    I'm using LibreELEC 11 and the RPi4 is connected thru the soundbar and i also tried to connect it directly to the TV,but it's always recognized as a PC.


    HiassofT sorry to summon you here,but iiirc,you also have an LG OLED ,so do you have any recommendations ?Thanks you!

    I switched to LE11 as daily driver ,so i will let you know if this issue will occur at some point (the bad part about being a daily driver is that i can't keep the debugging always on).


    As a side note,regarding USB on Rpi4 ,I'm pretty sure i bumped into this several times -> https://github.com/raspberrypi/linux/issues/5192 <-- but in my case it was the other way around ,removing the Wi-Fi USB dongle caused a system freeze (using SSD as boot drive) .

    ghtester how often it happens on your other configuration ,the one running from USB-SATA adapter ?


    I'm asking because i'm testing this ,but after 24h+ the system is still running fine.


    I don't have a DVB-T stick available ,but my system use a SSD (boot ) connected thru USB-SATA adapter (connected to USB3) and a Sonoff USB Dongle (Zigbee Coordinator) connected to USB2.

    As the title says,i have an issue with my TV remote not working after turning the TV on (from standby).I must say that i'm trying to fiind a fix for this issue since a year or so and is present on both LE10 and LE11.So let's start with my current configuration:


    OS - LibreELEC 11

    Device - RPi4 8GB

    TV - 40 inch Philips TV (2010 model)

    Sound - Hisense HS512

    Other connected devices - FireTV 4k


    TV Connections :


    RPi4 (HDMI0) --> Soundbar (HDMI2) --> TV (HDMI1 ARC)

    FiretV 4k --> Soundbar (HDMI1) --> TV (HDMI1 ARC)


    Steps to reproduce:


    1) LibreELEC is running and CEC remote works

    2) Power OFF the TV but don't switch to another TV input ( sounbar is also put to standby )

    3) Power ON the TV ( soundbar is also powered ON )

    4) Kodi UI shows up as expected and sounbar is also set to the correct input (HDMI2) but the remote control is not working

    5) Opening up the TV inputs menu is showing LIVE TV as currently selected

    6) Manually switching to LibreELEC input from the TV input menu fix the issue and the CEC remote control is working again


    Remarks:


    I tried several CEC Adapter configurations,setting the correct physical address,HDMI port,connected device.etc) but nothing worked and also noticed that the physical address value wont't always stick and is automatically changed


    I thought that is caused by the soundbar ,because when it's powered ON it has a 5-8 seconds delay ,but that's not the case because on FireTV 4k everything works just fine


    Another side-effect is that switching to LiveTV input is also affected,meaning that it swirch to LiveTV input just fine but audio is not switched to ARC so there's no audio output on LiveTv ( this also brings WAF to a critical level) . Switching back to LibreELEC input and back again to LiveTV will fix the issue (wife will still complain though).


    Looking at the logs is seems like the active source is not set correctly,but i'm not really sure about it,so maybe you guys can spot something usefull in these logs.


    Logs:


    cec-client-scan.txt

    remote-working.txt

    cec-tv-on-off-on.txt

    cec-switch-source-to-libreelec.txt


    But no logs from you so far...

    I'm trying to help,but if can't reproduce ,i can't get any useful logs.

    I don't know what relation might be between "TV OFF" and a USB failure ,it looks more related to HDMI or CEC (and that's what i'm trying to find).


    You said that CEC is disabled ,so try enabling that .

    Also ,you could try switching to a different HDMI port on Rpi4 .


    There's clearly a regression on the newer LE11 builds ,but without logs is almost impossible to find out what's wrong .

    I'm also using a SSD for boot,but usually ,if there's an error with the USB crapping out,then you shouldn't be able to access the device thru SSH.


    That makes me think that your issue is different from the one reported by the OP.


    Best thing would be to enable debug logging before powering OFF your TV,then ,after the error occurs ,grab the logs (you can do it from the SSH with the "pastekodi" command ).

    I tried to reproduce the issue a few days ago ,but i couldn't ,so i will try again asap.


    Did exactly what you did,shutdown the TV and after 3h powered on again....no problem .


    BTW ,my RPi4 is connected to a Soundbar which is connected to the TV via HDMI ARC.


    CEC is also enabled .

    I never tried personally ,but it may be possible by editing :

    Code
    /storage/.kodi/userdata/addon_data/service.system.docker/congig/docker.json

    This is the line that yiu should try to modify ,by replacing the default path with your external drive:


    Code
    DOCKER_DAEMON_OPTS="--data-root=/storage/.kodi/userdata/addon_data/service.system.docker/docker"

    After LibreELEC-RPi4.arm-11.0-nightly-20220925-b1d73ad whenever i turn my tv off for a couple of hours

    or over night (i never shut my Pi 4 down, just reboot on ocasion when up or downgrading) and turn it back on it says No source, but all the leds on the Pi4 is flashing like normal.

    If i downgrade to LibreELEC-RPi4.arm-11.0-nightly-20220925-b1d73ad everything is back to normal,

    i can shut down my tv over night and turn it on again in the morning and start watching movies as usual.

    My Pi 4 boots from USB-connected SSD.

    It seems like your issue is different than the one from the OP.


    When you get the "no source" issue ,you can still reach the RPi4 thru SSH?


    Have you tried to manually switch your TV sources (eg. From RPi4 to LiveTV and back to RPi4 input)?


    If SSH connection is still working ,then you could try to restart Kodi via "systemctl restart kodi".If that works ,then it might be related to CEC ,not an usb issue.


    However ,i will try to reproduce the issue on my RPi4 8GB + SSD boot.