Anyone using an HP Thin Client T430 with either LE 9 or LE 10? Mine keeps crashing

  • Hey all,


    I was speaking with another member HDGuy , who has successfully installed LE10 on a T430. i managed to get my hands on a couple of them and attempted to run LE9 and LE10.


    No luck. I can install it and run it without issue, but after I get a few addons installed (Google Drive, Trakt Youtube etc) both of the devices freeze after about 10 - 20 seconds. Logs here

    External Content pastebin.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    If anyone has had any luck with this model, or has any ideas, I'm open to anything.


    Cheers,

    Ken

  • Thanks for the info Klojum. Sadly the memory is built into the motherboard. I ran a memory check on both and they are fine.


    Cheers,

    Ken

  • Code
    2021-09-18 04:37:57.812 T:139920263327360   DEBUG: LogindUPowerSyscall - Received unknown signal NameAcquired
    2021-09-18 04:37:57.812 T:139920263327360  NOTICE: Quitting due to POSIX signal

    That is looking unusual - receiving unexpected signal, quitting and google drive addon is hanging on exit.


    1. 9.2 is EOL, logs of 10.0 are preferred (although I can follow the idea old release for old device).


    2. Use pastekodi to generate logs, it may include more information.

  • Thanks smp , yes I tried running from USB and also installing on the NAND. The exact same issue was experienced.


    I think at this point I have thrown away $90 lol.


    Cheers,

    Ken

    • Official Post

    I think at this point I have thrown away $90 lol.

    Two HP T430? Not very likely that both devices have broken hardware. Activate debug logging at GUI (HUD will appear), reboot, run pastekodi and post the resulting link.


    Also have a look at the EFI / BIOS setup. Maybe this setup is the culprit.

  • Hey Da Flex thx! Yes, I have checked the BIOS a few times, it is pretty limited, nothing seems out of the ordinary. Exctly my thoughts - can't be 2 devices with duff hardware!


    The above paste log is a full debug log. The Kodi only loads for like 10 seconds and then restarts. Subsequent debug logs are identical.

    • Official Post

    OK, so I had deeper a look at post #1. I also think the error is related to an add-on, and the hardware is fine.


    From what I see at the log, the Google cloud add-on could be the culprit. I'm not familiar with Google cloud - maybe it's just a setup thing.


    Generally you should find the faulty add-on by trial-and-error. Uninstall add-ons step-by-step until you get a working system.


    PS: 45$ for an HP T430 is a steal by the way. In Germany I have to spend 199€ at least.

  • As I said in the Intel build thread my HP T430 runs LE no problem. The one I got has a N4020 w/2GB and a 16GB emmc drive. There are two different T430 models, the 2GB one runs ThinPro 7.0.2 (essentially a Linux graphical shell terminal) and the 4GB/32GB one runs Windows 10 IoC. I was a bit confused because HP’s website doesn’t really make this clear- had I known this I would have spent a little more for the 4GB version, which is much more useful for running other applications. That said, the 2GB version is perfect for LibreElec, so if that’s all you want to do with it, it fine,


    For $45 this thing is a steal, even with only 2 cores it’s faster than my Odroid N2, and can decode any 1080p stream thrown at it, including 10bit anime. The box itself is built like a brick- I opened it up, it’s got a nice solid heatsink (fanless) with a metal static shield on top. The wifi card has been removed, but you can easily replace it. Along with the hdmi output it has a display port and a usb C output.


    Only thing negative I can say is the LibreElec build is a little buggy, a few of the addons I’ve tried, particularly the Widevine ones will hard lock it.


    I’ve seen the 4GB version of the T430 go for in the $60 along with a Windows 10 IOC key. If you can find one it’s well worth that. Even the 2GB is worth it if all you are looking for is a solid LibreElec box to stream from your NAS. The thing really impresses me, I wish I could return it and get the 4GB one.