9.2.7 and 9.2.8 crash upon boot RPi 400

  • Hi all!


    I'm having this very weird problem. I have searched the forums and couldn't find a solution.


    I use LibreELEC on a Raspberry Pi 400, booting off a SanDisk SD card, 64GB.


    In short, when I (try to) upgrade from 9.2.6 to 9.2.7 or 9.2.8 (I tried both, with the same results), it does not boot anymore. I see the splash screen and then the RPi shuts down. The power LED turns off and I can hear the external HDD power off when this happens. So it's really powered off, not a display/cable issue or anything.


    All this happens very early in the boot process and the syslog does not contain anything about it.


    Information that I have gathered:

    • 9.2.6 and previous versions have been working great for several months now (I forgot when I got the RPi 400). Before this, I had been using incremental updates of LE from the same SD card for years on an RPi4 and an RPi3.
    • The exact same SD card, with 9.2.7, booted fine on an RPi4. I haven't tried this with 9.2.8, but I think it's safe to assume it would be the same.
    • I have tried several power supplies, with the same result: the RPi400 official one, a laptop supply from a Lenovo ThinkPad of [email protected] and a smartphone charger of [email protected]
    • This is really interesting
      • I tried to downgrade from 9.2.7 to 9.2.6 using a "raw" (downloaded) image and after, the issue was still there with 9.2.6. It wouldn't boot.
      • However, after I restored a previous image of 9.2.6, which I had backed up a few months ago (just the system partition), it worked. It booted fine.
      • Again, I haven't tried the same with 9.2.8, but I think the result would be similar.

    In fact, after the bad experience I had with the upgrade 9.2.6 -> 9.2.7, I wanted to stay on 9.2.6, but the lack of support for widevine became an issue. I tried to upgrade to 9.2.8 in the hopes that this might contain the fix for my issue, but no joy.


    In any case, I would exclude the SD card or power supply as possible causes, which are the only suspects I could find on the forums.


    Any suggestion will be appreciated.

  • LE 9.2 doesn't support the RPi 400 as it's firmware is too old. You probably manually replaced the firmware files on 9.2.6 and those got changed back to the stock (i.e. too old) LE ones when updating to 9.2.7/8.


    You have to replace firmware files again, or switch to LE 10 (which is the better solution as that will also give you working bluetooth and wifi).


    so long,


    Hias

  • Thanks for the hints.


    I had tried an update to LE10 alpha or beta a few months ago, but had trouble getting all my addons to work, so I reverted (I think that is why I had a 9.2.6 image laying around).


    I have made some changes a while ago, trying to get WiFi and BT to work, but I didn't manage and defaulted to USB dongles. I also have Hyperion running off this RPi 400, but I don't think I made any firmware changes for that - just enabled SPI in the config file (same as on RPi4) - it was some time ago and I don't completely remember.


    In any case, in all such instances, the worst I have ever had was that the hardware was not working. It has never happened to me that the RPi400 would not boot.


    So what you're saying is that I might try to overwrite the contents of the folder 'firmware' from my old image to the current and I might get lucky?

  • You have to replace start.elf and fixup.dat on the FAT partition - see here RE: LibreELEC (Leia) 9.2.5


    Note: last time I tested that was more than half a year ago and you might have to use an older firmware version (from 6-9 months ago) as it's not guaranteed that newer firmwares work with older kernels (or vice versa).


    so long,


    Hias

  • Understood, thank you. I might just do that.


    I tried the upgrade to LE10beta, but the showstopper turns out to be Hyperion NG not working (I think it was the same last time I tried the upgrade).


    I found this thread where you explain that it basically doesn't look good. I also found on their forums where they say LE must implement the grabber. Looks like a stalemate. Bummer about that one. :(

  • Is this part of this topic?


    I would really appreciate to get Ambilight with LE 10 - but i guess this take approx one more year ;(

  • CvH No, I didn't mean to insinuate that it was trivial. Just that it is sad in a personal sense, because even Raspbian would not be an option, if worse comes to worst. I was just trying to make a little joke, perhaps not in the best taste. I appreciate the work everyone is doing on both sides.


    HiassofT Yes, I noticed that too, so fingers crossed that it leads to a solution. Still, it sounds like it will take a while.


    JohnWayne111 Hopefully not so long, but let's see.



    In the meantime, just to perhaps bring this thread to a conclusion, I can report that, indeed, flashing 9.2.8 and replacing start.elf and fixup.dat from my old working image solved the problem. I must have changed them and forgotten (and that would have been 8 months ago, so it's strange that I have absolutely no recollection of it - I must be getting seriously old). So it looks that those of us who want to use Hyperion are for the moment stuck at 9.2.x, with this workaround in the case of Rpi400.


    For me personally, that is not actually an issue, as for the moment I don't have plans for the good stuff from LE10. And for WiFi and Bluetooth I've been using dongles I had laying around and got used to it. And Hyperion is honestly too beautiful to give up. :) Especially after putting time and money into making it (not a lot, but still).


    Let's just hope Widevine doesn't completely break that before we get a solution for LE10. I'm not sure how long the LE team will be willing to support the 9.2.x branch with such fixes.


    Thank you all for your support!