[Help] Install on nand LibreElec on MXQ S905X bricked

  • Good evening to the whole forum.

    Sorry for posting here, but I have a big problem with the Tv Box as per the title.

    The box worked perfectly before trying to update Aidan's Android 7.1 via Aml usb burnig tool.

    I tried to flash about 70 roms, but to no avail; the burning tool always stops at 4% or 2% I tried different pc, different m / m usb cables, different versions of aml_burning, but nothing .....

    Yesterday I connected the box with UART, soldering the strips on the mainboard of the box and connected to the pc via serial with putty (115200): the device communicates with the pc, but on the terminal you can see a string of strange characters and a few letters / numbers; i tried to stop booting by hitting enter, ctrl + c, but nothing ....

    From what I have read on the net, there are hundreds of clones of this device, so you need the specific firmware for this device.

    Now I ask you: is it possible to somehow install LE directly on the nand via aml usb burning, or via usb / sd?

    MB: MXQ_S95X_V2.0 20161020, 1GB / 8GB memory / flash

    Processor: S905X Wi-Fi: S9082C

    Android 6.01

    On the box label is: OTT TV BOX X000N2ZCNN ITFBA-MXQ-S905X GooBang Doo IT MXQ 6.0


    Thanks a lot to everyone

  • Now I ask you: is it possible to somehow install LE directly on the nand via aml usb burning, or via usb / sd

    Amlogic Burning Tool = No (our .img is not the format used by that tool). USB/SD = You can boot from SD/USB but we provide no tools for internal install (the box has emmc btw, not nand but that doesn't change anything) and you will need working vendor u-boot on the box to boot into LE (or CE, which is probably a better option for clone box). Currently there are no LE releases for this kind of box.

  • Ok, thanks a lot chewitt for the clarification. I'm fine with just booting from sd / usb, without installation on emmc.

    I cannot find the supplier u-boot as it is a box that I have already owned for some years. One last question: I would like to do some tests by downloading various u-boot.bin.sd.bin on the net and try to boot dtech 9.2.7 LE with external dtb; exactly how can i proceed? Thanks so much

  • If vendor boot firmware is present on emmc the box will always boot from it, so to freely experiment with other boot firmware(s) from an SD card or USB stick you will need to completely erase emmc. If the goal is to run the dtech image you should focus on finding a replcement "vendor" u-boot. NB: the u-boot.bin.sd.bin files in my share (in case that's what you found) are mainline u-boot variants and might boot the box but will not greatly help in any mission involving 3.14 vendor kernels. Start by sharing the "strange characters and letters/numbers" seen via UART via pastebin so people can understand what the current boot-state of the device is.

  • Thanks a lot chewitt for your availability.

    I took a screenshot of the characters on the putty terminal.

    I'm interested in starting the box with LibreElec, from usb, sd or any other way.

    Thanks so much


  • That seems like noise. What baud rate did you set? 115200?


    Do you use MAX232 to connect to the TTL port?

    Please calm me down, that you did not solder the serial port RxD and TxD pins directly to the device. :-/

  • Yes, 115200

    yes, I used a max232; on the box I soldered the strips so that I can insert the connectors. So do you think it may be a serial interface malfunction?

    Edited once, last by jimjack12 ().

  • It is an interface that was loaned to me by a friend built manually;

    the 5v I took them from the USB box.

    Now I have returned it to the owner, and even buying a uart / usb adapter it would arrive no earlier than the end of August. However I believe that I have deleted both the firmware and the bootloader of the box, in fact on the tv via hdmi there is only a black screen.

  • The functionality of the MAX232 IC can be tested by connecting the RX and TX pins together and typing a character into the terminal.

    If the typed character does not appear or only noise is displayed, then the reasons may be as follows:

    • the power line is broken: Vcc is missing or GND is floating (broken wire),
    • the voltage is unstable or lower than +5V,
    • the Maxim IC is faulty.

    If the MAX232 receives Vcc voltage (+5V) and the GND pins are also connected between the power source (such as USB port) and the other devices (RS232 pin 5 and the GND on the UART port of the box), the converter power should be OK.


    If the bootloader has been overwritten (or just erased its area), I have a strong suspicion that we will not get anything through UART.

    But I have never met one like this before, so I don't know for sure. I think chewitt has more experience with this.


    At what percentage does the USB Burning Tool stop?

  • In the meantime, thank you very much for your patience and availability.

    During the flash, I tried them all: normal erase and full erase flash, erase bootloader, etc ... trying the various combinations. However, on about 70/80 roms you try, for the most part, the writing process stops at 4%.

    Initially, after trying some Android 7 roms, you could see the "S905X" logo on the screen, but you could start using LibreElec sd. Now, however, after several tests, nothing is seen on the screen and it is not possible to start LibreElec from sd.

    It should be noted that the aml burning tool immediately recognizes the box and there is no need to press the reset button inside the AV hole.

    Thanks so much

  • I looked at the pictures taken from the PCB:

    [v7.5] Aidan's ROM [S905X] [ATV 7.1.2] (Lag & Bloat Free, Pre Rooted, Samba & Miracast) [TV NETFLIIX] 2021 Update! | Page 31 | XDA Forums


    This version has 4 x 256MB of memory, which is relatively rare solution. (The 2 x 512MB solution is the most common.)

    Most likely this is why most bootloaders are not good for this specific model.

    We should look for stock ROMs that have the same 4 x 256MB layout.

  • Thanks a lot dtech for the effort and availability.

    Unfortunately, today, while I was trying another couple of firmware, a power surge due to a storm completely burned the box; it means that he had to die like this .....


    Luckily I still have another mxq pro g9cx S905x with your LibreElec 9.2.7 version running 100%.

    Actually, by the way, I still have to test the new 9.2.8 release.

    Thanks for everything and good luck to everyone.

  • Unfortunately, today, while I was trying another couple of firmware, a power surge due to a storm completely burned the box; it means that he had to die like this .....

    God has spoken. ;)

    Flexin' vinyl, jammin' break beats. 8)

  • Thanks a lot to everyone.

    However it was a salvation: I was losing my head behind this damn box .......


    Fortunately, the voltage surge didn't cause any further damage.

    However, I am delighted to see that you are all special people and I am delighted to be a part of this beautiful community.

    Good luck to all and resent :mio:


    ;)