IAGL (Internet Archive Game Launcher): Most games not working

  • Guys, I don't know what's wrong over here and I need help:

    I've just set up IAGL for the first time and there are indeed a few games that do work, but most games do not.

    For the debug logfile I first tried to start Street Fighter II which makes LE crash completely (black screen and after a few seconds it puts me back to the login screen (without rebooting completely, btw)). Then I've tried to start Super Mario Bros. 3 which just aborts with the error message that I should check the logfiles.

    Here is the debug logfile:

    Logfile

    Any help would be appreciated, thank you in advance.

  • Hello,

    I'm the addon author. There looks like there's an issue with vfs.libarchive/Kodi with LE based on the log. The error is:

    Code
    Create - unsupported protocol(archive) in archive://path_to_zip_file.zip/


    Which is an error I've never seen. It points to LE not supporting the archive protocol. I'll have to dig into this a little more.

  • Hello,

    I'm the addon author. There looks like there's an issue with vfs.libarchive/Kodi with LE based on the log. The error is:

    Code
    Create - unsupported protocol(archive) in archive://path_to_zip_file.zip/


    Which is an error I've never seen. It points to LE not supporting the archive protocol. I'll have to dig into this a little more.

    Good news, at least to me, that it seems not to be my mistake :D

    Edit: Thank you for answering my question and for helping me out with this, mate

  • So i tested this with IAGL version 3.0.0 and with the latest version (3.0.4) and can't recreate this issue. The extraction of archive files seems to work just fine for me. In doing some research, I'd recommend just verifying you have the latest vfs.libarchive/vfs.rar installed and activated in your addons (they're in the LE repository).

    (Discussion of similar issue here)

  • Thanks for your investigation.

    I had a really hard journey today to make everything work after a lot of hours messing around with IAGL on LibreELEC.


    First thing I did was to check your hint:


    vfs.libarchive/vfs.rar were already on the latest version and active, so that hint did unfortunately not help anything.

    So I decided to reinstall LE10.0 RC1 from scratch and after the first start I was indeed able to run some games which did not work before, but unforunately only once and then not again. I mentioned that on the very first run of a game I was asked for choosing an emulator but on further starts of the same game(s) I was indeed aksed again but the strange thing was that some emulators were disappeared and did not show up anymore altough they were indeed installed.

    I was messing around with re-installing IAGL a few times and I tried to download emulators from different repositories but nothing helped.


    Then I thought the problem could be the use of multiple user profiles in LibreELEC. I wanted to give it a shot and installed LE10.0 RC1 again from scratch without multiple user profiles and "Bingo!", that was it. I don't know what exactly the proplem is according to multiple user profiles but maybe you can find out and/or tell me/us.


    But: Even without the use multiple user profiles I still ran into a strange issue:

    After the installation of the IAGL addon, for setting everything up, I chose to use the wizard which was asking me for "archive.org" login. After putting my according e-mail address it told me that the e-mail address was not found within the "archive.org" database. After inserting the same e-mail address again the e-mail address was accepted somehow. Then, on the next step, it asked for the according "archive.org" account password. After inserting the password there was a message showing up that some games may not work without a registered "archive.org" account, but what's pretty disturbing abut this message is that it won't tell you if the password was right or wrong, it's just this message. So you have no idea if the message was just an additional information or if it was an explicit warning because of a wrong inserted password.

    Then, after installing all emulators and downloading all game lists, on the very end of the wizard, the setup assistant showed up "Setup could not be completed to launch games with RetroPlayer" which gave me a bad feeling again. And indeed I was not able to run most of the games. So I went through IAGL addon settings and mentioned that the "archive.org" account I have inserted on the wizard was not being saved so I tried to insert it via the IAGL addon settings manually again. Then I checked for "account confirmation" (I don't remember how exactly the option is called within the IAGL addon settings) and got the message that the account was found successfully.

    After that I was able to run all games I have tried yet (I will test more games these days and report back if something does not work).

    Just to be clear: I did all those steps twice from scratch and as described on the official IAGL Github instructions, just to be sure that this was not happening because of a mistake of myself (which am pretty sure right now).


    Plus, if you don't mind, I would like to set an "improvement request" for the IAGL setup wizard: It would be very convenient to have an option to choose to install all available emulators without having to confirm every single one of them to be installed (which is obviously pretty annoying because there are a lot of them).


    Thank you and if you have any question or need any further information I can provide, I am happy to help.

  • Thanks for the info. I fixed the profile bug and that will be included in the next release.

    Unfortunately, for the installation of addons in the wizard, I can only have the addon 'request' installation and the rest of the steps are handled by Kodi directly. For security reasons I surmise they won't let an addon auto install things without the users explicit agreement (which I think is a good idea). I can add some more warnings/info into the wizard to make the process a little clearer.