sd card to ssd disk clone

  • Hello

    what is the best way to clone my sd card to a usb ssd.

    I have already tried with many means I do not want to succeed.the Raspi 4 b does not want to boot from the SSD.

    When I plug sd card into a USB adapter the Raspi boots fine from USB.

    Raspi 4, Argone One m.2,LibreElec 10.0.0

    • Official Post

    the Raspi 4 b does not want to boot from the SSD.

    Did you already upgrade the RPi4's firmwares for booting and USB3.0 controller?

    You can also directly install the LibreELEC diskimage onto the SSD, and then copy over all userdata and config folders. That way, resizing the partitions will not be a problem during a clone.

  • Yes everything up to date.

    No it is NOT - at least your bootloader is a bit outdated, the latest stable release is dated 2021-04-29 and beta 2021-05-19 (rpi-eeprom/ at master · raspberrypi/rpi-eeprom · GitHub).

    It looks your portable SSD is not detected, it could be due to incompatibility with RPi's bootloader or due to insufficient power.

    Please note that RPi 4B has a quite low power limit on USB ports (even though you have a good power supply) so an external power for attached external disks is a good option.

    Also try connecting the SSD to USB 2 ports.

  • The Raspi 4 also does not want to boot from a USB 3 stick.

    USB 2 sticks all work for me.

    On Kodi at updates, however, only the version from 03.09.2020 is offered.

    How do I get the latest version installed?

    Raspi 4, Argone One m.2,LibreElec 10.0.0

  • Kodi does not search for latest available RPi's firmware releases so it depends on LE build you have installed. If you use a stable but old LE release (9.2.6), also the RPi bootloader offered is obsolete.

    See for instance here:

  • I have renewed the bootloader and USB firmware according to your instructions.

    But the bootloader is still from 2020

    What am I doing wrong?

    Raspi-Schlafzimmer:~ # vcgencmd bootloader_version
    Sep  3 2020 13:11:43
    version c305221a6d7e532693cc7ff57fddfc8649def167 (release)
    timestamp 1599135103

    Raspi 4, Argone One m.2,LibreElec 10.0.0

  • Booted with "LibreELEC-RPi4.arm-10.0-nightly-20210604-f6b7711.img.gz" and a USB2 stick and installed the latest firmware.Worked very well.

    After that I copied the same build to my SSD with RUFUS.

    The first time I got as far as the colorful screen.

    After the next boot the system complained that the firmware is missing.

    Then it did not boot at all.

    From my SanDisk Ultra USB 3.0 16GB the Raspi does not want to know anything.the is not found at all.

    What else can I try?

    Translated with DeepL Übersetzer - DeepL Translate (free version)

    Raspi 4, Argone One m.2,LibreElec 10.0.0

  • Bought a new USB 3 stick today.Libreelec on it and works.

    Tomorrow I get a "SSD M.2 2280 256GB GamerKing Ngff internal Solid State Drive 250 GIG" for my Argon One M.2 case.

    Let's see if this works without problems.

    Raspi 4, Argone One m.2,LibreElec 10.0.0

  • Is it possible to set the Raspi to boot from USB at startup and not to search for the sd card first?

    Raspi 4, Argone One m.2,LibreElec 10.0.0

    • Official Post

    I think that delay is only a few seconds. Not searching for the SD card would a setting in the firmware, not something LibreELEC could force, I imagine. Anyway, how often are you planning to reboot your RPi? :)

  • This is just my media center in the bedroom.This is turned on and off after use.

    In my opinion, a few seconds can make a difference.

    Raspi 4, Argone One m.2,LibreElec 10.0.0