cma-512 crashes LE10 in RPi4 ! [SOLVED]

  • I've lost some hours to understand why my RPi4 started to crash at boot after installing newer le10 nightly builds.


    After some tests I've noticed that the line in distroconfig.txt:

    dtoverlay=vc4-kms-v3d,cma-512

    Is the one to blame.


    If I remove cma-512 from distroconfig.txt, Le10 works just fine.

    I have a RPi4 with 4 GB RAM.


    What could be happening ? (the previous le10 builds did not had cma-512 and also worked ok).

    No one else had the same problem ?



    Thanks :)

  • Go to Best Answer
  • If I remove cma-512 from distroconfig.txt, Le10 works just fine.

    Personally, I don't see the problem with that. I have never used cma settings in any LE release, and LibreELEC ran just fine.

  • I'm not using it either!


    It simply comes with every release from the past weeks,, but my rpi4 simply crashes at boot if I have it selected.

    I have to manualy disable it, placing the sc-card in my pc and manually editing distroconfig.txt.


    Is cma-512 needed ?

    could it be possible to NOT being enabled by default ?


    thanks

    • Best Answer

    Did you by chance change gpu_mem in config.txt? If yes: don't do that, keep it at the default of 76 or you will experience crashes - LE10 needs lots of CMA memory, not GPU memory.


    so long,


    Hias

  • Did you by chance change gpu_mem in config.txt? If yes: don't do that, keep it at the default of 76 or you will experience crashes - LE10 needs lots of CMA memory, not GPU memory.


    so long,


    Hias

    yes !

    That was the issue.


    Thank you very much.

    Solved

    :thumbup: