Kodi 19 fails to start on old intel gpu with i915 because it loads the wrong libva_driver

  • Hello again.


    This is the continuation of this issue on kodi's github.

    Minimum opengl version for kodi 19 under linux · Issue #19521 · xbmc/xbmc · GitHub

    As lrusak suggested there, I open this thread to continue the discussion here. Also, I have found a few more minor issues while running the nightly builds the last ~10 days.


    Hardware specs.

    An old intel celeron t3000 and its intergrated gpu, plus 2gb of ram

    Code
    # lscpu | grep Model
    Model name:          Celeron(R) Dual-Core CPU       T3000  @ 1.80GHz
    # lspci -k 
    00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
    Subsystem: Lenovo Mobile 4 Series Chipset Integrated Graphics Controller
    Kernel driver in use: i915

    Libreelec version: The latest nightly as of today April 24th 2021, i.e. nightly-20210423-5701db2.

    Log: Any available log is mentioned in the issue's report in github.

    Steps: Also mentioned in the issue report.


    So, the suggested solution does work, but I think it would be nicer to have a script that "auto" selects the proper driver for libva based on the gpu driver that is used, e.g. something like this one

    External Content gist.github.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Also, could that variable be set to i915, because that is the driver the kernel uses for that gpu? I assume not, but I wanted to ask anyway.


    Moreover, I also assume that setting that variable in there overrides any other. I tested it on my niece's 10th gen nuc and it lacked hardware acceleration even on h264!


    One more minor issue on the above system is that it reports -1Mhz as the cpu speed under system info > hardware.

  • Then its libva's maintainers to blame for that "misconfiguration"? Great :(

    I will probably upgrade my main installation from 9.2.6 to 10beta2 tomorrow (or in the following days) and call it a day with the nightlies. Feel free to close this thread if you think there is no other thing to discuss about it.

    • Official Post

    I'm not really sure which misconfiguration you are talking about?


    The libva driver shouldn't crash when initializing on old hardware and should gracefully fallback to the older libva intel driver.


    A bug report should probably be made to the media-driver github repo about that.

  • lrusak

    Maybe the word misconfiguration is not the right one. But how shall I describe what you mention in the second sentence, which is what really happens? That is why I think the forementioned script is a good workaround, because it sets this parameter on the fly.

    Also, is there something can I disable under settings > player > videos > postprocessing that will help the situation? Like disable vaapi altogether? :/


    mglae

    Has this patch been added to le's code as of today? I just upgraded to today's nightly-20210425-999da98 and the problem is stil there.

  • Goodmorning everyone. I noticed earlier that 2 of yesterday's commits had to do with libva and intel.

    So, I just upgraded to the latest nightly (20210427-59c8aa4) and removed the forementioned lines from .config/kodi.conf to test it. And it worked!


    Thank you so much!

  • Is there a repo that I can use and get the nightly updates as regular ones through le settings?

  • This is where I get the url of every new nightly build for x64 (the next morning) in order to manually update my existing installation. I have never noticed the releases.json folder file at the bottom though. Let me see what can be done... Brb.


    ---edit

    It worked. I simply entered the url under custom channels and the nightly build was instantly shown under available versions. Since the installed version (20210503-83202cd) is the same as the one in the repo, I will wait and see what will it do tomorrow.

    Edited 2 times, last by jim_p ().

  • As I am still waiting for releases.json to be renewed and include today's nightly upgrade (1da9953, after days with no new nightlies due to no new commits in github), I would like to report 2 things.


    1) For some reason and as seen on the screenshot, the update... mechanism thinks that the installed version is different/older than the one in the repo, although they are the same. That "10.0-" part at the front seems to mess things up.


    2) If I press yes there and allow the update, now that the forementioned file is no longer in the repo, no warning/error/notification pops up inside kodi to let the user know it failed. In the log however, the 404 error is clear

  • Can someone PLEASE update the releases.json file from test.libreelec.tv so as to reflect the new images and allow me to upgrade via libreelec settings? I have been waiting for this moment for an entire week and I can't do it because the most critical file has not been updated for the last couple of nightlies.

    • Official Post

    As I understand, it's a file that is not generated automatically, and also not everyone has access to edit the file.


    I know that a proper/working update channel would be nice, but for now it is what it is.

    There is still the option to update LibreELEC manually. No need to wait a week doing that.

  • Well... it was working a week ago... I suppose. Because I found out about it when I did my last manual update.

    I do know how to update manually (= download the update via wget inside the .update folder) and I have done so since I first started with the nightlies, but now I want to see how will it behave for the reason mentioned above (= the mismatch in the version number).

    Also, the option in libreelec configuration > updates > available versions leads to what I say above with the 404 error.

    Edited once, last by jim_p ().

  • I got bored of waiting so I manually upgraded to today's nightly-20210510-39d1620. I hope the issue will be fixed soon.

  • jim_p The shown "New Version" string is defined by the update file.


    flubshi To get the expected result try:


    Code
     @@ -1,6 +1,6 @@
     {
         "LEnightly-9.80": {
    -        "prettyname_regex": "^LibreELEC-.*-([0-9]+\\.[0-9]+\\-.*-[0-9]+-[0-9a-z]{7})",
    +        "prettyname_regex": "^LibreELEC-.*-[0-9]+\\.[0-9]+\\-(.*-[0-9]+-[0-9a-z]{7})",
             "prettyname_separators": [],
             "project": {
                 "Generic.x86_64": {