Intel NUC 8i5BEH - HDMI Sound problem

  • Bios Keys (if unknown):

    F2 bios config./settings

    F7 bios update (with *.bio on an usb stick, OS independent Bios updates)

    F10 boot menu

    Tips regarding Win install:

    - you could use the link from comment #13 "c't Notfall..." => the first 64 bit, german

    - don't let you trick by MS's insist (insistance ?) to need an online account during install (use Domäne beitreten ...)

    - the rest of setting during install: as you wish and no need to spent a lot of time

    - if it comes to that point somehow: don't use the driver offered by windows update (they are downsized), use only (!) the Intel one's from their site

    Tips regarding driver (in that sequence):

    copy-pasted from the readme in the "Bundle Drivers":

    1. Intel® Chipset Device

    2. Intel® Management Engine Consumer Driver

    3. Intel® Graphics DCH Driver

    ?. Intel® Serial IO Driver (don't know which function is has, but it won't hurt)

    ?. Intel® Ethernet (isn't necessary for the HDMI update)

    ?. Realtek* High Definition Audio Driver (last time I didn't install it for an HDMI update)

    that's all driver we/you need.

    - reboot Windows after driver install so that all driver are sharp

    - you'll find in the device manager some unsatisfied entries - cause we didn't install all driver -

    - chipset and most important graphic should be satified !

    - HDMI is an extra download (not in the bundle) !

    - HDMI update works without LAN/WIFI


    a) BIOS ?

    last is 87.

    is yours current ? (NUC booted with F2-Key pressed/tapped)


    either it's in the bundle too or later (anytime and any OS) via an '.bio on an usb stick

    b) Secure Erase SSD (if needed)

    - software comes from your manufacturer

    usually (I got a Samsung SSD) they build an usb stick to boot with. (suprise: they boot an linux :love:)


    I thought that you're an german


    I hope the whole effort works out regarding your initial sound problem.

    DigiBit R1, NUC8i3BEH

    Edited 6 times, last by JoeAverage ().

  • Please keep us posted about the update procedure and whether it fixes the issues.

    I've got a NUC8 i3 hooked up to an old AVR, so passthrough and whatnot isnt an issue for me. But once the AVR kicks the bucket it would be nice to know how to fix this problem.

    *fingers crossed*

  • Thomas_AR

    Today I flashed the HDMI successful, but some hints:

    VC runtime

    you need one or two additional files, otherwise the HDMI-Update-Tool will run in an error (see attached Photo)

    both files from here:

    Aktuelle unterstützte Downloads für Visual C++

    for x86 and maybe for x64

    I first installed x64 (on the 64 bit Win10), but the HDMI-Tool wasn't happy, so I installed x86 too.

    I guess the HDMI-Tool depends on x86, so it should be sufficing to install only x86, but if not: also x64


    if you read the "NUC8ixBE-HDMI-FW-Update-Guide-Version" (in the tool directory) you will find that the version numbers in the graphic aren't current, esp.: the new HDMI-FW check after the update !

    so here is what I get (after the update):


    Current on-board F/W Version: Bobcat App: MC2800 v1.78.4 (cut2.2)

    CMDB: Ver:0.3 (Custom Ver: 0.3)



    if you have trouble to find the known Gerätemanager in Win10:

    in the (File-)Explorer right-click on "Dieser PC" => "Eigenschaften": top right (in fullscreen mode) => "Gerätemanager"

  • Folks, hadn't found the time over the weekend to update everything. Still summer here and girlfriend is keeping me busy. But will do everything soon.

    Meanwhile I recognized that sound less than 48khz is not playing in the current configuration. Let's wait until I made all the updates. Keep you posted.


  • I've had some issues with passthrough before. Then it did help to disable and re-enable passthrough in the settings. There was a time when this workaround was required in older versions of LibreELEC (or even OpenELEC) - have you tried this?

  • I do not believe it.

    As the Win10 iso is larger than 5GB i had to format the USB Flash Drive as exFat. When booting the NUC with F10 the USB Flash Drive isn't recognized.

    What did i forget?

    Getting mad.. my old Asus Chromebox worked perfect....


    Edited once, last by Thomas_AR ().

  • ...

    Any special BIOS configuration needed?



    apart from the above bios key to boot the usb stick.

    for the record:

    I always do with a second box running windows or - in my case - a VM running windows:

    in an terminal with admin rights

    1. diskpart

    2. list disk

    3. select disk N

    4. detail disk

    5. clean

    6. create partition primary

    7. format fs=ntfs quick

    8. assign

    9. active

    10 . now, I only need to copy the content (not the iso) from the windows-10-DVD to the usb stick.


    for 3.: "N" is the number for the usb stick.

    for 4.: to be sure I selected the correct disk: the stick, because 5. cleans all data ! (wrong disk => all data lost !)


    - I'm independent from MS (- tools)

    - I could be sure that the stick is bootable, otherwise the stick is bad

    - I could use a Windows DVD laying around

    DigiBit R1, NUC8i3BEH

  • THX for clarification, I didn't know that EFI is unable to boot EXFAT/NTFS - hadn't had M$ its finger on the EFI spec's ?! -

    I know that EFI needs a FAT partition, therefore I always didn't use EFI, at least not in my Linux systems.

    Why should I ?

    the same for ~secure~ (cough) boot.

    I also know FAT32 is limited with 4GB.

    I'm currently unsure if I have booted my usb stick used in comment #22 with efi or not, anyway both, EFI and normal boot (legacy ?) were enabled in the bios and the NUC booted NTFS fine.

    I guess the MS-Creation-Tool builds an stick with EFI on it.

    - EDIT -

    i checked what you said, and it seems to be invalid.

    attached are two photo's:

    1. a screenshot of the linux disk manager => NTFS

    2. after pressing F10 Key during boot => UEFI (legacy boot was switched OFF before)

    hitting enter turns out:

    Windows install USB stick, created as described in comment #28, boots from NTFS with UEFI !

  • Ok,

    Installed WIN10, updated all driver as explained obove by Joe, HDMI updated. Bios I updated before the install of WIN 10.

    Reinstalled LE latest stable VERSION 9. PROBLEM remains.

    With WIN 10 GUI sounds worked perfect. LE 9 nothing.

    Going crazy 😂


    Edited once, last by Thomas_AR ().

  • With DSP disabled no sound at all.

    I think as missing sound works with the 3.5 headphone out it should also work with spdif out. Will connect via aux a Nakamishi Sound system. Let's see, have to buy a splitter to aux. Will be analog but better than now. Or buy a home theater with spdif connector.

    Anyway as WIN10 GUI sound work fine with my TV it's strange that LE doesn't.

    It seams to be a Intel Nuc related problem as LE 9 and my Asus Chrome Box worked perfect with the same TV.

    Thanks to everybody trying to solve this mistery.


  • If you have installed all available updates from the manufacturers homepage, then I can only suggest to try the new LE 10 Beta. /shrug

    Flexin' vinyl, jammin' break beats. 8)