No SMB after new install and more...

  • Hi


    I had to reinstall everything and i have forgotten about how to or maybe things have changed.

    I can't use SMB on my Mini PC / LibreElec no more. I've tried to use other ways to get all my stuff installed again but even when i can add a path to my external hd connected to my router it doesn't scrape it and put it in my Kodi listing of available music / movies / photos.


    What have i done wrong? I read somewhere that SMB 3 is the minimum today ....

    Asus s1-at5nm10e - Netgear READY NAS 102 - Wired - Receiver Pioneer VSX-529-K - ASUS RT-AC58U - USB HDD connected Seagate - SONY BRAVIA KDL-55W955B - Netgear ReadyNAS 102

    • Official Post

    SMBv2 or SMBv3 work "out of the box" and SMBv1 requires you to reconfigure the Kodi smclient to use min/max SMBv1 (and perhaps legacy security) if that's all the ancient samba version in the router will support.

  • SMBv2 or SMBv3 work "out of the box" and SMBv1 requires you to reconfigure the Kodi smclient to use min/max SMBv1 (and perhaps legacy security) if that's all the ancient samba version in the router will support.

    So the router have a part in this? My arkilles heel when it comes to computers is networking setup. :) Could you please be more specific?

    Where should i start? I have changed the SMB minimum and maximum to several different settings but nothing helps.

    Asus s1-at5nm10e - Netgear READY NAS 102 - Wired - Receiver Pioneer VSX-529-K - ASUS RT-AC58U - USB HDD connected Seagate - SONY BRAVIA KDL-55W955B - Netgear ReadyNAS 102

  • Just to eliminate the SMB version:

    You could try to set You LibreElec box to use SMBv1 (not recommended!)

    You can set the required SMB version in LibreElec settings.


    <EDIT>

    Note!

    SMBv1 is obsolete and outdated. Usage should be avoided!

    </EDIT>

    => Just my 5 cents...

    ..//Jocke.Sve

    Edited once, last by Jocke.Sve: Added SMBv1 warning... ().

    • Official Post

    Common mistake #1 is setting the Kodi smbclient "min" to SMBv1 and "max" to SMBv3 because "that covers all options!" but this means Kodi will connect with SMBv2 which is now the smbclient default (as SMBv1 is considered insecure) which is incompatible with the router which only speaks SMBv1. The only way to force Kodi to use SMBv1 is to set both min and max to SMBv1.


    Common mistake #2 is configuring the LE samba (server) share options in the LE settings add-on, which have nothing to do with the Kodi smbclient (client) settings which are in Kodi settings > services > smb client.

  • Common mistake #1 is setting the Kodi smbclient "min" to SMBv1 and "max" to SMBv3 because "that covers all options!" but this means Kodi will connect with SMBv2 which is now the smbclient default (as SMBv1 is considered insecure) which is incompatible with the router which only speaks SMBv1. The only way to force Kodi to use SMBv1 is to set both min and max to SMBv1.


    Common mistake #2 is configuring the LE samba (server) share options in the LE settings add-on, which have nothing to do with the Kodi smbclient (client) settings which are in Kodi settings > services > smb client.

    Thanks, tonight you're my hero pointing med in the right direction. :)

    Asus s1-at5nm10e - Netgear READY NAS 102 - Wired - Receiver Pioneer VSX-529-K - ASUS RT-AC58U - USB HDD connected Seagate - SONY BRAVIA KDL-55W955B - Netgear ReadyNAS 102