File system corruption has been detected after installation

  • Hi there,


    I'm using a brand new Pi 4 model B with 8Gb of memory in combination with a class 10 16Gb SD Card.

    I used the Libreelec download for Windows to prepare the memory card.


    After preparation I got the file system corruption error and after I contacted my supplier I received a new card. Unfortunately this was not fixing the issue, I keep on getting the same error, see attached screen shots. I also installed the same Libreelec software on an old spare 2Gb SD, which is working as it should, no problem, only slow as it is probably a class 2 or 4 card.

    I tried several options for installation (2 different PCs, the Libreelec software but also the PI Imager), all giving the same result. I also did a low level format of the card in between.


    Based upon this information my first thoughts were the 2nd card was also defect, but that was too much of a coincidence to me, so my next step was the installation of Raspberry PI OS (32-bit) on the same card using PI Imager. This all works fine, no errors on the card, the OS was updated, I could start Thonny, run a small Python program etc.


    Do you know whether there is an issue with the mentioned configuration? Or do you have any alternatives I can try?


    Thanks in advance,

    André

  • You could try Etcher to write the microSD. Etcher will check for errors after writing, and it's approved to work with LE.

    Flexin' vinyl, jammin' break beats. 8)

  • You could try Etcher to write the microSD. Etcher will check for errors after writing, and it's approved to work with LE.

    Thanks for your prompt reply, tried Etcher, but is giving me the same error, although the Etcher validation was successful.


    (As beginner I had to wait 40 minutes before I was able to reply :))

  • Thanks for testing. The official standard for Rpi is SDHC. If you use an SDXC card, it could produce reading errors. This means, your card is fine, but the RPi is unable to read it correctly.


    PS: Normally 16GB is SDHC, but it looks like they use SDXC internally for some of those cards, too: Example on Amazon. Maybe you should buy another microSD from a different company.

    Flexin' vinyl, jammin' break beats. 8)

  • The card is SDHC, the supplier is a company specialized in Rpi, they deliver the Rpi with card, so I assume the card is correct.


    For me the strange part in this story is I am able to format and put a Raspberry PI OS on the same card without any issue, it's just the LibreELEC (the part I want to use the Rpi for mostly) that's giving the error.

  • Understand. Please give the LE download link that you've been used.

    Flexin' vinyl, jammin' break beats. 8)

  • Looks like you did everything right. Hmm, this error is unusual. I assume you don't use overclocking. It could be a hardware defect. The "Raspberry Pi OS" has logging capabilities for sure. Run that OS and read the log from time to time. Maybe you find a defect.

    Flexin' vinyl, jammin' break beats. 8)

  • Just an update that my issue is solved.


    Today I bought a 16Gb SanDisk Ultra microSDHC Class 10 card and retried from start and to my big surprise it is working!


    So I guess there must definitely be something wrong in my previous 2 cards...

  • As I said above, it's possible that some cards use SDXC internally, and they will work fine inside other card readers.

    Flexin' vinyl, jammin' break beats. 8)

  • sh, I'm glad you got it working.


    For what it's worth, I've switched my LibreELEC machines to M.2 SSD drives. With current firmware, a Pi will boot from a USB 3 attached drive. It's super fast and you don't have to worry about your SD cards flaking out over time. Even a low end SSD can handle a lot more write cycles than a TF card.


    As a bonus, it boots much faster from SSD. UI response seems about the same though, even when it is accessing the library. My library is small so perhaps I probably wouldn't notice a library speed improvement unless it was huge.