Bluetooth 5.0 Realtek RTL8761B Support

  • I have a Raspberry Pi 2 and the lastest version of LibreElec. Everything works great (thanks).

    I had an old Bluetooth 2.0 (15 years old) that worked fine, but sometimes there was some interference in the audio.

    Now I have bought a bluetooth 5.0 (Realtek RTL8761B) that does not detect, I think is a problem with the drivers, according to what I have searched on the internet.

    The bluetooth works fine, I tested it in mi Windows and checked also that it is Bluetooth 5.0 (HCI 9.55449 / LMP 9.25805).

    Is there a provision to soon include the necessary drivers? Are they already included and do I have to activate something?


    • Official Post

    It might be missing the firmware, in which case you'll need to share "dmesg | paste" output so we can see the error message that tells us which file can't be found (so we can pick/add it).

  • Wow, so easy :)

  • Code
    mkdir -p /storage/.config/firmware/rtl_bt
    wget -P /storage/.config/firmware/rtl_bt

    The config file is optional.

  • I executed both commands and nothing, the result is the same:

    I tried also with 777 permission in the new file with the same output.

    Maybe I have to do something more, I dont know :(

  • Oh :S

    How I to install a nightly build? I search in the options and the option to update non release version not appear (or I dont know how).

    The second option sound more complex :S I can wait for the fix to be included in the next release (assuming it isn't in 1 year :) ).

    Thanks for your responses.

    • Official Post

    current master

    I pr changes as soon I fixed it.

  • Oh, perfect. Many thanks. I download LibreELEC-Generic.x86_64-9.80-nightly-20201217-76a852d.img.gz and the firmware.

    Does the update go inside /storage/.update?

    Does the firmware go inside /storage/.config/firmware/rtl_bt?

    And the last question (I hope). When updating this version, will the system continue to update automatically? And, with the next update will the change be lost?


  • If you are still using a RPI2 you do need LibreELEC-RPi2.arm-9.80-nightly-20201218-76a852d.img.gz

    > Does the update go inside /storage/.update?


    > Does the firmware go inside /storage/.config/firmware/rtl_bt?


    > When updating this version, will the system continue to update automatically?


    > with the next update will the change be lost?


  • Thanks for the advise about the version.

    And, when the new version will was release, will I have to update it manually?

    I saw that file: LibreELEC-RPi2.arm-9.80-nightly-20201218-76a852d-noobs.tar.

    I have Noobs in my Raspberry (Libreelec and Raspbian). It is not a problem for install LibreELEC-RPi2.arm-9.80-nightly-20201218-76a852d.img.gz file?

    Tomorrow I will try it.

    Many thanks.

  • Oh :(

    LibreELEC-RPi2.arm-9.80-nightly-20201218-76a852d.img.gz didn't work for me :(

    With the config file of the firmware:

    Without the config file of the firmware:

    And all addons are now uncompatible =O

    Oh sh..t :( I think that it works with the last nightly build, but the problem is I not read correctly your message... Ouch :(

    Luckily I had the backup of LibreELEC (Leia) 9.2.6 :)

    I will keep this version until you confirm that it is already supported.


    Edited once, last by TasTraceur ().

  • I have a bluetooth adapter that uses this chip

    I install LibreELEC-Generic.x86_64-9.80-nightly-20210125-b8007d5.img.gz

    [ 9.957581] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [ 9.957585] Bluetooth: BNEP filters: protocol multicast
    [ 9.957591] Bluetooth: BNEP socket layer initialized
    [ 11.686198] Bluetooth: hci0: command 0x1001 tx timeout
    [ 13.203735] e1000e 0000:00:19.0 eth0: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
    [ 13.203887] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [ 13.218570] 8021q: 802.1Q VLAN Support v1.8
    [ 19.792863] Bluetooth: hci0: RTL: HCI_OP_READ_LOCAL_VERSION failed (-110)

  • I've thought better of it and I'm going to try this option:

    Or self-compile from a libreelec-9.2 branch and add a patch for RTL8761B support.

    Because now everything works perfectly, so I prefer to modify the version I have to include only bluetooth.

    Now I have Librelec 9.2.6 (kernel: Linux 4.19.127) with Kodi 18.9.0 Git:newclock5_18.9-Leia from 2020-10-25.

    Can someone help me with an explanation of how I should compile for the Raspberry Pi 2 the same versión with only the modification of the bluetooth?

    A lot of thanks.

    (I put the firmware in the firmware folder of Raspbian in the same Raspberry and works without any other change)

    Edited once, last by TasTraceur ().