Wetek play 2 build

  • The box image should work fairly well on WP2 except for DVB support (there is none) and some of the fancier bits like HDR to SDR conversion (also missing) and 3D support (which never really worked in the vendor kernel either). The only add-ons I'm aware of that continue to have issues with Kodi 19/20 and Python3 are pirate ones, and I think it's brilliant if those don't work.

  • chewitt sorry just another hopefully not too dumb question. If installing the 'box' version to get basic matrix support, is there any file renaming/editing required to make it boot from standard SD card....? I note there was something posted re storage naming...unsure if that is required for SD card boot...sorry.

  • It's a while since I booted WP2 from vendor u-boot but worst case you might need to trigger recovery mode as the u-boot bootscripts in the box image are a little different to ones used with the legacy kernel. There's no dtb renaming or such needed.

  • chewitt So this LibreELEC-AMLMX.arm-10.85.0-box.img.gz is the one I should use NOT LibreELEC-AMLGX.arm-10.85.0-wetek-play2.img.gz...correct?

    ...for WP2 SD boot no tuners needed...

    ooops the AMLGX 'box' image not the one above...

    Edited 2 times, last by 2Old2Slow (April 2, 2022 at 4:05 AM).

  • Ok so I attempted to boot the 'box' image after using the cd creator to create the bootable Sd card...but it doesn't seem to want to boot...I'll keep trying...or go the other route maybe...thanks for your patience with me....

  • chewitt Hi, so I've tried a few times downloaded the LGX box image a couple of times in case it was corrupt but can't get the WP2 into recovery made via toothpick method...it will go into recovery mode from the Android install in eMMc but that doesn't help me.

    So once I plug in the power and release the pin after 10 seconds it sits there cycling with nothing on the screen other than the TV recognising a source on and off...never gets to the recovery script.

    Any ideas?

    I probably should know this but what is the LibreELEC-AMLGX.arm-10.85.0-wetek-play2.img.gz in your testing area used for? Or is that the full eMMc image?

  • There is no recovery script; it should prompt the box to re-read the u-boot scripts (s905_autoscript etc.) which will load the LE kernel file and dtb into memory and boot them. I'd need to see UART (serial console) output to understand where it goes wrong - it's always worked for me and others in the past. WeTek did ship UART cables with the box but I'd expect most folks to have chucked it out by now? - The wetek-play2 image boots the device from SD card using upstream u-boot; but only if the eMMC has been erased (removing vendor u-boot) first, and the best way to do that is booting the device from the box image (catch 22).

  • chewitt Thanks for the explanation, yeah I don't understand why its failing...it continues to boot from SD into 9.0.2 of LE no problem...I'll persevere and if anything actually happens I'll let you know...thanks again.

  • Hi chewitt , I much appreciate your work with this devie. Now I am back again fighting against my wetek play 2, and need to know where can I download the last stable version of LE that supports DVB-S tunner and works from the SD, as for all the links above are dead.

    The idea is to use the wetek play 2 as a tvheadend server and use an Nvidia Shield TV as client by plex, tivimate or any other app that you recommend.

    Thank you very much.

  • chewitt I'm a ninny went back through this thread and I managed to miss the .dtb renaming step...renamed to correct meson filename and bingo worked without needing toothpick...thank you for all the hard work to keep this box working.

  • chewitt Do you have an earlier Matrix box version...seems some of my matrix addons don't show up in this Kodi 20 alpha version. Android Kodi 19.3 on my shield works fine.

    I guess its the 9.80.x 'box' image I need based on a previous post you made here...or wait for the addons to be made compatible.

    Edited once, last by 2Old2Slow (May 10, 2022 at 4:47 AM).

  • chewitt Do you have an earlier Matrix box version...seems some of my matrix addons don't show up in this Kodi 20 alpha version. Android Kodi 19.3 on my shield works fine.

    I haven't build against Matrix for some time (more than 6-months) now so there are no builds stashed anywhere. From what I see in Kodi team chat most add-ons should be Matrix/Nexus compatible by now .. there might be some exceptions.

  • chewitt Ok thanks I came to the party too late I guess thanks for your efforts again...I'll wait to see if the addons get updated at some point. BTW the build is very good and works fine with a few of the addons.

  • Hi chewitt,

    I'm using a build from April of LibreELEC-AMLGX.arm-10.85.0-box.img.gz and the video jumps a little on h265 encoded videos.

    Does the newer images add any improvements on that area?

    Should I backup my /storage before dd the new image in the sdcard or will it keep the /storage content?

    Thanks in advance and best regards,