[Add-on Youtube 5.2.1] [Kodi Krypton] Invalid Credential

  • Hi,


    I have a problem with the Youtube plugin. I can connect without any problem by entering the code twice, I finally have the Daily Limit Exceeded error after a particular time in the evening.


    So I created my own Personnal API Keys but I get the error message Invalid Credientals when I consult History, Subscriptions, Browse Channels, ... except My Subscriptions that works very well.


    I checked more than 10 times that my API Key, API Id and API Secret was entered correctly.


    Are you help me solve my problem?
    I can also provide the log if necessary.


    Thank you
    Winjet

    Edited once, last by Winjet ().

  • You should contact the Addon author for support/troubleshooting.
    Have you isolated the problem installing just the addon from a fresh install?

    Beelink MiniMX III 2GB/16GB gigabit LAN
    LibreELEC running from SD card (will confirm version on post).

  • 1. do not include the .apps.googleusercontent.com extension when you save/enter your Client ID


    2. Sign Out your Kodi YouTube addon > and after Sign In again (with the normal 2 x web activation)


  • 1. do not include the .apps.googleusercontent.com extension when you save/enter your Client ID


    2. Sign Out your Kodi YouTube addon > and after Sign In again (with the normal 2 x web activation)


    Hi,


    Thanks to help me


    I removed the extension you like me asked (.apps.googleusercontent.com). I reconnected but as soon as I took the first code, I get the error message Login Failed.


    If I make the two activation codes without my own Personnal API Keys, I can log into my account. I then reactivates and I still get the same error message :


    Invalid Credientals or Kind Unknown ( depending on the choice as option ).


    I even tried with a freshly installed version of Kodi (only Youtube addon) but it's always the same.

  • I found a version 5.2.2 of the Youtube addon that works perfectly.


    After some research, it turns out that previous versions of the addon doesn't work correctly with Kodi Krypton.


    I don't understand why all the tutorials I looked they put .apps.googleusercontent.com in the Client ID.


    But thank you all for the help and without the advice removing .apps.googleusercontent.com I would still be looking for a solution.

    Edited once, last by Winjet ().

  • I've been using the stock add-on from the Kodi repo on boxes for ages without issues. No need for all the hacking..


  • I don't understand why all the tutorials I looked they put .apps.googleusercontent.com in the Client ID.


    But thank you all for the help and without the advice removing .apps.googleusercontent.com I would still be looking for a solution.


    I did the same mistake: many tutorials don't specify that.


    The official guide is here: YouTube Plug-in Thread (look for YOUTUBE PERSONAL API KEY INSTRUCTIONS by jmh2002)