Kodi and VNC don't start if no monitor connected.

  • I'm running Kodi on RPi 4 and I have enabled VNC. My purpose is to use remote desktop from Win 10 to start music playing on Pi, but I cannot connect unless there is a monitor connected via HDMI. To me this seems to defeat the purpose of the remote login. If I connect a monitor everything works again, but I can't run like that permanently.


    I have ordered an HDMI dummy plug with which I hope to fool LibreELEC that there is a monitor connected, but this is a very clunky workaround. Is there no way to force Kodi and VNC server to start IRRESPECTIVE of whether there is a monitor connected or not?


    If there is no way to do this at present, I would suggest it as a future upgrade.

  • You can dump EDID from a TV to file and then configure the RPi to use the file. Then Kodi "sees" a TV connected (even if it isn't) and it will start, and VNC will be able to show the screen. It all sounds like complete overkill when you can use the Kodi web interface or mobile phone "remote" app to browse the library and select something to play though.

  • I'm running Kodi on RPi 4 and I have enabled VNC. My purpose is to use remote desktop from Win 10 to start music playing on Pi, but I cannot connect unless there is a monitor connected via HDMI. To me this seems to defeat the purpose of the remote login. If I connect a monitor everything works again, but I can't run like that permanently.


    I have ordered an HDMI dummy plug with which I hope to fool LibreELEC that there is a monitor connected, but this is a very clunky workaround. Is there no way to force Kodi and VNC server to start IRRESPECTIVE of whether there is a monitor connected or not?


    If there is no way to do this at present, I would suggest it as a future upgrade.

    Kodi and VNC are 2 different services...VNC works even with kodi disabled..

    No need of a dummy..you can add

    Code
    1. hdmi_force_hotplug=1

    in config.txt

  • I've got same problem on generic.. Need to have TV connected to get running. Where do I need to add hdmi force hotplug thing? ;)

  • I've got same problem on generic.. Need to have TV connected to get running. Where do I need to add hdmi force hotplug thing? ;)

    I don't think that will work on generic..probably is just for raspberry pi...for generic see here