RPI 3 - LibreELEC 8 and 9 + Samsung TV - can't get kodi screensaver to turn off backlight (long shot, i know)

  • i've been having this problem lately where the dim screensaver can't be used to turn off the backlight of my samsung TV. i know it worked in the past without any addons or getting more screensavers, but at some point in the versioning from 8.x, the backlight stays on (which is bad for the tv) even when dim is set to zero %.


    there are some screensaver addons for the RPi LCD that turn it's backlight off, but they don't work with the samsung tv. there's one screensaver addon that turns off the tv totally, but then you have to physically turn the tv back on (which is again bad for the longevity for the tv). best would be something to send some kind of signal that would trigger the tv to just turn off the backlight.


    there could be an issue with the tv settings or the video output settings, but those haven't changed over time (that i know of). the tv's firmware did get updated along the way, and i didn't notice when the backlight wasn't going off right away... but i don't think i'm the only one seeing this as an issue going forward.


    i did find another post in the kodi forums about this, but it ended after three posts without a solution.


    i also found this thread that talks about setting the backlight level:

    Change HDMI monitor brightness (aka backlight) from OSMC/Kodi - Raspberry Pi - OSMC Forums

    - which i think could be used to send a backlight = zero command as part of the screensaver, but i'm sort of out of my depth at that point.


    in any event, i'd like to know if anyone else had seen this issue, specifically with RPi 3 or higher, Libreelec 8 or higher, and any TV, but especially any recent Samsung TV (best if it is 4k and HDR capable - though i run libreelec at 1080p), or even if they haven't, even with a different tv or a computer monitor.


    best, of course, is if someone has figured out a way to get it to work, perhaps with an addon.


    any help or commentary is welcome, thanks!