Mount is not supported

  • Hi, I want to mount my NAS drive but I keep failing on so basic operation as a mount. When I use this:


    Code
    1. mount -t cifs //192.168.1.20/video /storage/nasvideo -o vers=3.0,username=myUsername,password=myPass,rw

    I get this this result:

    Code
    1. mount: mounting //192.168.1.20/video on /storage/nasvideo failed: Operation not supported


    So withount this working I can't make anything described in Mounting OS Level Network Shares | OpenELEC Mediacenter


    Any idea what to do, please?

  • Hi Nicolas, well it's similiar to link which I posted but it is not working. So I wanted to know why it's not working and use just mount command which also wouldn't work.


    In your link is a status command which I tried and it returns this:

    So I'm reading that operation is not supported but I don't know why or what to change to make it work

  • Not sure what does that mean. I can't use mount at any time. Not a simple mount via SSH, not via script described in links here. It looks to me like whole mount operation is not possible in LibreELEC. But I have fresh install and doesn't change anything there...

  • So cat wrote this (username and password I changed here but it's correct and I tried it from another device):

    and there is a ls command

    It shows nasvideo folder but there isn't anything mounted inside.

  • ScottyCZE


    You haven't told us anything about the software you are using to share the drive (ie. what is your NAS on 192.168.1.20).


    Is it a LibreELEC host? Or Windows? Or something else? What version of whatever software are you using?


    It looks to me like SMB3 is either not supported or not enabled on the NAS, so you should either enable SMB3 (if the NAS supports it) or try connecting with a lower protocol (ie. vers=2.1, vers=2.0 etc.).


    If the NAS only supports SMB1 you may need to include "sec=ntlm" as an option, and of course specify "vers=1.0".

  • Thank you very much milhouse! Problem wasn't probably in mount command but really in NAS settings. There was SMB 1-2 allowed. When I increased max supported version to SMB3 it all works. Thank you very much!