Volume Control for Chrome Add-On

  • Hi there,


    I run a current LibreELEC setup on i3-6100 and analog audio. Within Kodi / Kodi core functions the volume settings works as wanted, but as soon as I start e.g. an Addon like Google Chrome the volume is set to its maximum and there seems nothing to be done against it. Is there someone who could tell me how to change the volume in add-ons? The usual Volume-Up&Down keys do not work.

  • Please check whether editing the volume setting of guisettings.xml (bottom of the file) makes a difference for your apps.

    Flexin' vinyl, jammin' break beats. 8)

  • I change this setting

    Code
    <audio>
    <mute>false</mute>
    <fvolumelevel>0.500000</fvolumelevel>
    </audio>

    to

    Code
    <audio>
    <mute>false</mute>
    <fvolumelevel>0.100000</fvolumelevel>
    </audio>

    no change at all.


    There is no volume control at all possible when I open the Addon Google Chrome (installed from the defaul repository). Even the volume circle is missing, when I hit the volume key (which works fine while hearing music or watching tv).


  • Thanks for testing. Next you can try the alsa mixer this way:

    Code
    amixer -c 0 set Digital 80%

    Flexin' vinyl, jammin' break beats. 8)

  • Thanks for testing. Next you can try the alsa mixer this way:

    Code
    amixer -c 0 set Digital 80%

    Hello Da Flex,


    I am in the same boat here, running Libreelec over HDMI and I tried amixer with every variation and it has no effect at all. I tried aplay -l.


    I also ran the command

    Code
    amixer | grep mixer

    to list all available options there and I had Chrome open and tried them one by one, to no avail.


    I understand that pulse-audio wouldn't work, since that is killed right before starting Chrome addon.


    I am running:

    libreelec (official): 9.2.6

    Chrome addon: 9.2..0.104

    Intel NUC

    Edited once, last by AmandaB ().

  • It seems like Chrome has it's independent audio settings. You could search for audio config files inside the Chrome add-on folder.

    Another approach is to install the "Kodi Audio Mixer" add-on and try to find the right fader for Chrome.

    Flexin' vinyl, jammin' break beats. 8)

  • It seems like Chrome has it's independent audio settings. You could search for audio config files inside the Chrome add-on folder.

    Another approach is to install the "Kodi Audio Mixer" add-on and try to find the right fader for Chrome.

    Thank you for the pointers Da Flex


    That helped me to push it a tad further. Running the "Kodi Audio Mixer" add-on, I noticed that the only control that affected Chrome audio was 'IEC958',0.


    The issue now is that I can only mute/unmute (toggle) it, but amixer won't allow me to change the volume up or down (or "Kodi Audio Mixer", for the matter -- there is no volume slider next to "IEC958",0).


    The command that I ran was

    Code
    amixer -c 0 set IEC958,0 10%
    amixer: Invalid command!


    How would I investigate\fix this issue ?

  • AmandaB Please post the output of this commands:

    • amixer
    • cat /proc/asound/cards

    I should have posted the output of both commands earlier. Sorry about that.

    I just wanted to let you know that there was a word censored here in "Simpe mixer control 'Internal Mic bost',0". The word here was B-O-O-S-T

  • From the technical view the sound device is closed in Kodi and opened in Chrome.


    To control the volume in Chrome install and test one of the Chrome Sound/Volume Apps.

  • From the technical view the sound device is closed in Kodi and opened in Chrome.


    To control the volume in Chrome install and test one of the Chrome Sound/Volume Apps.

    Thank you for the suggestion mglae!


    I cannot say that I tried them all, but I tried more than my fair share of them.


    They either have no effect at all from the get go or they mute Chrome and once that happens no matter how high I set the volume, it stays muted.

  • AmandaB Please post the output of this commands:

    • amixer
    • cat /proc/asound/cards

    I provided the output of both commands in the previous reply.


    Is there a conf file to edit ? I think the issue here is related to some definitions in a conf file.


    Thanks,

  • Thanks for testing. What about amixer -c 0 sset IEC958 Default PCM,0 50%?

    Thank you for your patience, Da Flex !


    No output from amixer this time. but the changes had no effect on Chrome. I tried setting it to 5% then 100% after trying the 50% value.

  • I think you understand what I did. Play around with other device channels from post #9. Maybe it's a good idea to disable auto-mute first ("Auto-Mute Mode").


    I'm an RPi user, so I can't install Chrome to verify anything.

    Flexin' vinyl, jammin' break beats. 8)

  • I think you understand what I did. Play around with other device channels from post #9. Maybe it's a good idea to disable auto-mute first ("Auto-Mute Mode").


    I'm an RPi user, so I can't install Chrome to verify anything.

    Da Flex, Thank you for your help.


    I am out of my depth here. I tried every possible combination from post #9 and I tried with auto-mute disabled and enabled but to no avail.


    Hopefully someone would come along who can give me any pointers on why amixer has no effects on HDMI sound other than mute and unmute.