Posts by AmandaB

    That's great. I am pushing one step forward here.


    Here are the results of aplay -L

    When I first tried to get sound to Chrome. I knew that plughw was to set to plughw:0,3 to work.


    So Card was 0 and device was 3.


    When I tried that from the aplay results, I got no where. I would have Chrome playing audio and speaker-test running without issues.


    However, when I tried

    Code
    hdmi:CARD=PCH,DEV=0

    It worked when Chrome was not playing sound and failed to work when chrome was playing sound. So I figured, this is the right card and device.


    So next, it was time to test amixer volume change. I first ran

    So it was added there. But running

    Code
    amixer -c 0 sset PCM_MyVolume 100%
    OR
    amixer -c 0 sset PCM_MyVolume,0 100%
    OR
    amixer sset PCM_MyVolume 100%

    had no effect at all on what Chrome was playing.


    Is there any bindings that I should have done ? I tried rebooting to see if that was the issue, but that has no effect.

    Hello HiassofT ,


    I tried to get it running all day today but I need a few pointers if that's okay with you.


    When I looked at usr/share/alsa/alsa.conf to try to get the name of the slave PCM, I noticed that alsa set the devices dynamically, so I couldn't find a way to get the name of the device. So, I ran 'amixer' with the following result

    So, I assumed the slave PCM name to be "IEC958,0" since that the only one that muted the volume on my tests, with that in mind, i went ahead and created a new default device in the destination you told me with the name "asound.conf"

    Code
    pcm.!default {
    type softvol
    slave "IEC958,0"
    control.name "hdmi_out" <- I did not name it Master, since Master already exists.
    control.card 0
    }

    I do not see any results following a reboot.


    Can you give me any pointers on what I am missing here.

    I was just talking to him. Unfortunately this is an open issue, and he can't fix it at the moment. Sorry. ?(

    Da Flex, you went above and beyond. Thank you! At least I learned something new.

    The answer is simply that there is no volume control for the IEC958/HDMI outputs. Only the analog outputs have (software) volume control.


    so long,


    Hias

    HiassofT Thank you for the explanation! Just to clarify, is that by design or can that be modified in the alsa config file ?

    I think you understand what I did. Play around with other device channels from post #9. Maybe it's a good idea to disable auto-mute first ("Auto-Mute Mode").


    I'm an RPi user, so I can't install Chrome to verify anything.

    Da Flex, Thank you for your help.


    I am out of my depth here. I tried every possible combination from post #9 and I tried with auto-mute disabled and enabled but to no avail.


    Hopefully someone would come along who can give me any pointers on why amixer has no effects on HDMI sound other than mute and unmute.

    From the technical view the sound device is closed in Kodi and opened in Chrome.


    To control the volume in Chrome install and test one of the Chrome Sound/Volume Apps.

    Thank you for the suggestion mglae!


    I cannot say that I tried them all, but I tried more than my fair share of them.


    They either have no effect at all from the get go or they mute Chrome and once that happens no matter how high I set the volume, it stays muted.

    AmandaB Please post the output of this commands:

    • amixer
    • cat /proc/asound/cards

    I should have posted the output of both commands earlier. Sorry about that.

    I just wanted to let you know that there was a word censored here in "Simpe mixer control 'Internal Mic bost',0". The word here was B-O-O-S-T

    It seems like Chrome has it's independent audio settings. You could search for audio config files inside the Chrome add-on folder.

    Another approach is to install the "Kodi Audio Mixer" add-on and try to find the right fader for Chrome.

    Thank you for the pointers Da Flex


    That helped me to push it a tad further. Running the "Kodi Audio Mixer" add-on, I noticed that the only control that affected Chrome audio was 'IEC958',0.


    The issue now is that I can only mute/unmute (toggle) it, but amixer won't allow me to change the volume up or down (or "Kodi Audio Mixer", for the matter -- there is no volume slider next to "IEC958",0).


    The command that I ran was

    Code
    amixer -c 0 set IEC958,0 10%
    amixer: Invalid command!


    How would I investigate\fix this issue ?

    Thanks for testing. Next you can try the alsa mixer this way:

    Code
    amixer -c 0 set Digital 80%

    Hello Da Flex,


    I am in the same boat here, running Libreelec over HDMI and I tried amixer with every variation and it has no effect at all. I tried aplay -l.


    I also ran the command

    Code
    amixer | grep mixer

    to list all available options there and I had Chrome open and tried them one by one, to no avail.


    I understand that pulse-audio wouldn't work, since that is killed right before starting Chrome addon.


    I am running:

    libreelec (official): 9.2.6

    Chrome addon: 9.2..0.104

    Intel NUC