No Sound via hdmi

  • Hello,

    My configuration:

    Raspberry pi 4B LibreElec 9.2

    My problem: no fate sound from the hdmi socket (I'm talking about the one next to the jack). I tested with my amp which detects only the image, and the same by passing directly on a television.

    The sound works when plugged into Jack.

    In Kodi I specified output on hdmi, with and without "passtrought".

    Here is what I find in my /storage/.kodi/userdata/guisettings file:


    And here is also the file /flash/config.txt

    (I have already tried to add the line "hdmi_drive = 2") with reboot


    If someone has an idea .. is it possible that my micro hdmi cable is bad? (I have no other on hand at the moment)

    Thank you

    and by the way, a big thank you for the great work of LibreElec.

    Long live LibreElec! 8)

  • Quote

    <setting id="audiooutput.channels">8</setting>

    Set it to 2.

    Flexin' vinyl, jammin' break beats. 8)

  • Hello,


    Thank you for your response Da Flex.

    I changed the parameter to 2 then I restarted the system. It hasn't changed anything. So I went back to the configuration file and the parameter went back to 8 by itself. I am however sure to have saved the modifications before leaving.


    (Since yesterday I changed my cable hdmi but it doesn't come from either)

  • Activate "HDMI and Analogue" sound, and test analogue output on RPi's headphone jack.

    Disable I2C and UART for testing.

    Make sure your HDMI cable is HDMI 2.0 or 2.1 standard (ready for 4K).

    Flexin' vinyl, jammin' break beats. 8)

  • I'm having the same issue. Only sound from hmdi first port the one next to power source. No sound on the other. Seems like some configuration is needed from what I searched. Rpi4

  • Ok


    Tests:

    Headphones with hdmi+Jack (no changing config) = Sound in HeadPhones


    In the file /flash/config.txt:


    enable_uart=1 >>>> enable_uart=0 >>>> reboot = Sound in Headphones, no hdmi

    enable_uart=0 + dtparam=i2c=off >>>> reboot = Sound in Headphones, no hdmi

    enable_uart=1 + dtparam=i2c=off >>>>> reboot = Sound in Headphones, no hdmi


    Other test: saving Libreelec >>> RAZ LibreElec = Sound in Headphones, no hdmi


    I d/l soon raspbian for an another test: sound hdmi on raspbian?


    my new cable is hdmi 2.0 (with new micro hdmi adaptator vers. not spécified)

    Quote

    I'm having the same issue. Only sound from hmdi first port the one next to power source. No sound on the other. Seems like some configuration is needed from what I searched. Rpi4

    I think that you can only one hdmi port sound. The second is just for video. (i'm not sure)

  • Thanks for the tests. I compared your guisettings.xml to mine. I found a difference, which could be the cause:

    Code
    <setting id="audiooutput.dtspassthrough">true</setting>

    Set this setting to false.

    Flexin' vinyl, jammin' break beats. 8)

  • Hello..


    No it's not that .. I just booted on Raspbian and I have the same problem. I tell myself that this must be a material problem.

    Maybe, you have an idea Da Flex?

    In any case, thank you very much for the time you spent there!

  • OK, then I'm running out of ideas, too. Maybe you still have guarantee, and get a replacement. Try it on a friends TV before you replace it.

    Flexin' vinyl, jammin' break beats. 8)