RPi4 unstable: hangs, freezes, crashes, wheels spin, assorted non-working behaviors

  • My Raspberry Pi 4B with LibreELEC is very unstable. Some details:


    o Plugged into TCL 55"

    o Using LibreELEC (official): 9.2.1 (RPi4.arm

    o Changed video to 4k60p through modification of config.txt file.

    o Set wifi to stay on by adding LibreELEC addon iw, and adding file /storage/.config/autostart.sh with the line

    iw wlan0 set power_save off

    o Set WiFi zone to US by adding file /storage/.config/modprobe.d/cfg80211.conf with line

    options cfg80211 ieee80211_regdom=US

    o The only non-standard addon is Jellyfin

    o Connects only to 5GHz network, and appears to have a good signal, but not sure how to check that directly in the pi to be sure.

    o The power source and the hdmi cable are the official ones from RaspberryPi.


    I have wiped the OS clean and started over, but still happens. It hangs frequently, and the screen is frozen. I can sometimes ssh

    into the pi. Sometimes it then allows me to reboot. The problem is very intermittent, so it is hard to say how to reproduce it.

    I have a recent log file http://ix.io/2iOQ


    Any ideas about what is going wrong are appreciated.

  • Apparently the Jellyfin addon is have a couple of hiccups. Missing one database, locks in the other.. (You really watch jellyfins all day that you install an add-on?)

    How about watching some jelly videos with a default Kodi setup?

  • Firstly - don't add stuff and then say LE is unstable.

    Quote

    iw wlan0 set power_save off


    Should NOT be necessary

    Quote

    options cfg80211 ieee80211_regdom=US

    Should not be necessary if you have set your location in LE AND Kodi

    Quote

    The only non-standard addon is Jellyfin

    What about

    2019-04-11 11:28:40.303 T:3011779040 NOTICE: ADDON: virtual.network-tools v9.2.0.103 installed


    As @Klojum mentioned, your issue is with Jellyfin not LE. Either report the issue with Jellyfin or use Emby which might be more stable.

  • Thanks for your responses. If you don't mind, I will address both here.


    Klojum: The only thing I really use Kodi for is to use my own library, which is managed by Jellyfin. It helps to keep track of watched files, no matter what client I use. Not sure what you mean by "watching some jelly videos with a default Kodi setup". How does that even happen?

    I could add the same library as a network file to that instance of Kodi, but that would completely bypass Jellyfin. In fact, it would make the

    whole point of using Jellyfin to manage history impossible.


    Iridium:

    1. Turning off power_save was a recommendation by Chewit here. That recommendation is two years old, so may be obsolete. However, the behavior mentioned in that LibreELEC post still exists. Can you point me to where it is clear that this is no longer necessary? It made my wifi connectivity apparently more stable. Was that just coincidence?
    2. The recommendation to force the region is http://also by Chewit here. That recommendation is just a few months old. Has there been a change? It certainly made my wifi connectivity more stable.
    3. The addon: virtual.network-tools v9.2.0.103 was probably added by Jellyfin, and not by me directly. Hence, what I wrote above.
    4. I said that LE was unstable, because whatever the problem is just shuts down the whole system. Ordinarily, with Linux for example, even if there is a problem with some software, the whole OS does not become unstable. There are important exceptions, of course. Apparently this is one.

    At any rate, I will bring it up with Jellyfin. Finding out where the issue is, is everything.

  • Do you have 4K60 media? .. because 99% of people do not, and forcing it in config.txt results in higher power draw and other things. As nearly all 4K media is under 4K30 there is really no need to activate it.

  • I do have a few videos that are 4k60, but not much. Does the high power draw possibly cause the stability issues?

  • I suppose, but that seems like an issue to deal with after getting it to work under normal circumstances.

  • Do you have 4K60 media? .. because 99% of people do not, and forcing it in config.txt results in higher power draw and other things. As nearly all 4K media is under 4K30 there is really no need to activate it.

    in an another topic you wrote: to whitelist 23,97 24 50 59.94 and 60hz.


    If you do not force the code in config file then you could not see the hz rates above the 30.


    So these are two things

  • Is this the post that you mean? I tried whitelisting these frequencies, at the same spatial resolution. We will see. It is always so frustrating trying to troubleshoot these things when they are so intermittent, and the crash does not show up in the logs.