9.0.2 / WeTek Core: Random freeze (playback or not) for the last two weeks

  • Ahoy,


    I have a rather baffling behaviour with my WeTek Core running LibreELEC 9.0.2. It has been working juuuust fine since the update from 8.x. However, in the last two weeks, Kodi has been randomly freezing, and ultimately restarting, anywhere between a few minutes to an hour or so.


    Looking at one of the crashlogs, e.g. http://ix.io/2iv8, I'm seeing a seg fault, but I don't have enough context for it to make sense to me. It looks like it's somewhere in the network code. This happens both when watching media (local or streamed) or when not doing anything.


    My library is stored on a NAS, mounted as NFS, and the metadata is in a MySQL DB. None of this has changed recently.


    I have both Ethernet and Wi-Fi connections, but I've seen the crashes in both cases.


    I did recently install an addon to get to my Amazon Prime account, but have since disabled it, with no difference: still getting crashes. I am also seeing errors from the OzWeather addon, so disabled that too. To no avail.


    This is really surprising as I don't think much has changed, but those crashes have randomly started happening, which is a bit frustrating.


    I'm quite happy to dig in and run diagnostics on the box as needed, I just don't really know where to start.

    Edited once, last by shtrom ().

    • Official Post

    If you're running from SD card, perhaps try another SD card - they don't always last forever. If running from internal emmc, perhaps try running from an SD card - for the same reason. Otherwise I don't see anything obvious :(

  • I have the same setup since my Pi, Like yours.

    I tested everything. Downgraded the ethernet speed. Change from internal to a sd card. Clean install, android, all.

    I come to the conclusion that is the is hardware realated. The box just fail.

    Now I have a I7 4th box and the Wetek Core is sleeping in a drawer of my desk.

  • Got a new SD card from the shop, reflashed the 9.0.2 image and booted it up. After a backup restore, it seems to be holding the distance. I have still seen a couple of crashes, but the Core has been staying on without restart for 24+ hours, so it's definitely an improvement.


    I did disable the Wi-Fi connection, and only use the ethernet now, on a hunch as the segfaults seem to happen in the network code.

  • A concluding note on this: I fixed my issue.


    ...


    xkcd: Wisdom of the Ancients











    So, OK, my problem was fixed by simply making a clean install, and reinstalling plugins manually, rather than restoring a backup. The roots of that backup pre-date even OpenELEC before the migration to Libre, so there was a lot of cruft. FWIW, restoring the backup on a Raspberry Pi with LibreELEC 9.2.7 also causes some similar-ish hanging issues, which is what got me on the way.


    Still hoping to see the WeTek core get 9.2 or 10 one day, but for the moment, everything still seems to work, including Wedevine.

    • Official Post

    Martin Blumenstingl and I both have Core boxes now (Martin having one is vastly more important - esp. since I have littl time for Amlogic fiddling at the moment). Meson8 devices now have working HDMI (1080p) and initial audio support is on the mailing list so platform support has progressed. You can forget LE10 support, LE11 might be more realistic for alpha support; although Meson8 devices will soon be stuck at the same incomplete vdec support as all the newer Amlogic hardware versions. Most of the current activity originates from Lakka/Batocera devs as the S812 chip has a reputation for great performance .. and gaming doesn't need fancy stuff like vdec/4K etc.

  • Still hoping to see the WeTek core get 9.2 or 10 one day...

    Actually, I also created an image for WeTek Core on request, but the user for whom it was made has not logged in to the forum since April.

    So you would do me a favor if you could test it, because this is the only image I didn’t get feedback on whether it works okay or not.


    LibreELEC v9.2.8 image for WeTek Core:

    Index of /3rdParty/Semi-official/WeTek_Core/

  • Actually, I also created an image for WeTek Core on request, but the user for whom it was made has not logged in to the forum since April.

    So you would do me a favor if you could test it, because this is the only image I didn’t get feedback on whether it works okay or not.


    LibreELEC v9.2.8 image for WeTek Core:

    Index of /3rdParty/Semi-official/WeTek_Core/

    I don't suppose your build would include the SPDIF multi-channel audio device (last seen in official LE in 8.2.5); [8.95.3 Wetek Core] Missing multichannel audio output ????

    Martin Blumenstingl and I both have Core boxes now (Martin having one is vastly more important - esp. since I have littl time for Amlogic fiddling at the moment). Meson8 devices now have working HDMI (1080p) and initial audio support is on the mailing list so platform support has progressed. You can forget LE10 support, LE11 might be more realistic for alpha support; although Meson8 devices will soon be stuck at the same incomplete vdec support as all the newer Amlogic hardware versions. Most of the current activity originates from Lakka/Batocera devs as the S812 chip has a reputation for great performance .. and gaming doesn't need fancy stuff like vdec/4K etc.

    I've said it before, the Core and its relatively fast onboard flash , nice remote and optical out has me still checking back here in the hopes of getting it upgraded. Still a believer....

  • I don't suppose your build would include the SPDIF multi-channel audio device (last seen in official LE in 8.2.5); [8.95.3 Wetek Core] Missing multichannel audio output ????

    My build is based on 9.0.2, so if it didn't work there, my image probably won't work either.

    But I never had a WeTek Core, so I can't test it. I made the image on request, but it seemed to be a waste of time. :(

  • I don't suppose your build would include the SPDIF multi-channel audio device (last seen in official LE in 8.2.5); [8.95.3 Wetek Core] Missing multichannel audio output ????

    I've said it before, the Core and its relatively fast onboard flash , nice remote and optical out has me still checking back here in the hopes of getting it upgraded. Still a believer....

    Okay... Act 2: Now I have a WeTek Core too (UPDATED):


    Unfortunately, I can't try it because I don't have a Toslink cable or an amplifier that I can plug in this non-existent cable. /shrug

    Update: DD and DTS also work properly through SPDIF and HDMI as well. I bought a used Creative DDTS-100 decoder:

  • Okay... Act 2: Now I have a WeTek Core too (UPDATED):

    Update: DD and DTS also work properly through SPDIF and HDMI as well. I bought a used Creative DDTS-100 decoder:

    Oh my! Sorry for the delay in replying, I only check back from time to time but I will certainly be testing this soon and will report back my findings. I am very grateful, thank you!

  • Update: DD and DTS also work properly through SPDIF and HDMI as well.

    Can confirm, 5.1 pass-thru working perfectly!


    Thank you so much, this could be huge for me, so I hate to ask for more, but do you know how I might convert this to a NAND-installable package?


    Can't seem to find the 8.2.5/9.0.2 NAND installer downloads (no more http://archive.libreelec.tv/ ?) - though I have them here. But there were equivalent zip files the content of which would be extracted to a FAT32 card which when booted on would copy the 'recovery' image to bootable NAND memory.


    The zip contents were;


    factory_update_param.aml

    LibreELEC-WeTek_Core.arm-8.2.5-update.zip

    recovery.img


    And the contents of that zip looked like;


    bootloader.img

    KERNEL

    logo.img

    META-INF

    recovery.img

    system


    Just the operation from NAND is noticeably snappier. If not I can cope, probably by dual booting (9.0.2 from NAND, 9.2.8 from SD) but it would be the icing on the cake in terms of making the system current again.


    Also, is there an InputstreamAdaptive binary available for this build? My main motivation for upgrading is being able to stream from current DRM services.

    Edited 3 times, last by Ionman ().

  • It can be upgraded with tar from version 9.0.2, so I didn't even make a zip version of it. But before you do that...

    It is recommended that you back up your system before updating from my previous version (semi-official) or an earlier version of the official LibreELEC image (e.g. v9.0.2)

    So after backing up (and copying it from the device) you need to copy the LibreELEC-WeTek_Core.arm-9.2.8.3.tar file to the /storage/.update directory and then restart it. If you really have v9.0.2 installed on NAND, this is the easiest solution. ;)

    Also, is there an InputstreamAdaptive binary available for this build?

    Yes, sure. Although, I only tested it with the hGO EU addon before, but the hardware acceleration worked perfectly with it.

    (Unfortunately, all movies on HBO Go in my country are only available in stereo with local dubbing, and that is poorly down-mixed from 5.1. So I no longer have a subscription.)