RPI4 3D SBS out of wack kodi interface and picture

  • So this is a bizarre problem, I've got libreelec 9.2.1 installed on a raspberry pi 4.


    It plays normal films and 4k films fine, However when I attempt to put a 3d film that uses SBS format (and I have lots that I have used with a different kodi box that work fine), libreelec kodi detects that the film is 3d, it then does the following bizarre things (this is BEFORE I have switched the TV to 3D SBS mode).


    i) The interface changes to SBS (which is what I expect) so I get duplicate SBS interface BUT

    2) It then only display one half of the video (I think it it is the LEFT image) In FULL SCREEN.


    This means that when I turn the TV to 3D mode It tries to split the single LEFT image into a 3d SBS, which obviously goes wrong


    I have other KODI boxes which do not have this issue and can play the same 3d film fine and I am familar with specifying whether the image is in the movie preferred format or whether I should manually select SBS mode etc in KODI. This happens to all 3d films I have (I only have SBS ones as that is all my TV supports). I enclose an attachment showing what is happening, it should be showing two SBS images at this point (and yes this is BEFORE the TV has been switched to 3D mode).


    The problem here appears that the RPI4 Version 9.2.1 ones is turning the 3D VIDEO into 2D whilst turning the KODI interface into a 3D one where it should be leaving the Video unchanged so it shows both SBS images and turning the interface into a 3d SBS one.

  • I'm on LibreELEC 9.2.1 - Kodi build 18.6 Git:leia_pi4_18.6-Leia


    Having this exact problem, it's driving me nuts!


    Did you find a fix for it? I don't know where else to report the bug