9.2.1 on RPi4: HEVC from TV recording has no playback controls

  • Hi folks,

    just tried 9.2.1 on my RPi 4 2 GB. Thanks for all the work!

    I face a problem: Playing back HEVC .ts files that are recordings of DVB-T2 shows I have no playback controls, i.e. I cannot jump forward or backward. Only control available is stop. Tried a clean install to make sure I had no old clutter, but problem remains.

    If it helps, I can provide example files.

    Thanks for help!


  • Afterthought: Using CoreELEC on Le Potato the very same files work fine. Full playback controls available.

  • What hardware acceleration are you using?..try to change that in player settings..see if it makes any difference.

    Does video skip steps from remote?

    Edited once, last by Mario77 ().

  • Only setting I was able to find was switch mmal on or off. You mean that one? If so: No effect... If not: Please guide me to the relevant setting. Thanks!

    I also tried hdmi_enable_4kp60=1 in and out of config.txt. No effect, except that with it in my RPi gets unstable! Have no 4K display, so does not bother me...

  • Only setting I was able to find was switch mmal on or off. You mean that one? If so: No effect... If not: Please guide me to the relevant setting. Thanks!

    Yeah that's what i ment...just a tought.

  • Certainly worth a try, thanks for the input! Any idea how to proceed? Any logs that might make sense to pull?

    Can provide example video for anyone willing to check...

  • Hello!

    If you have some Samples I could try those.

    Maybe also a good Idea to provide a debug Log.



  • Here things are:

    Here's a screenshot of the playback - you can see: Only stop-control is there, no FF/REW or other controls.

    Please note: I'll at some point remove the file again - I in principle have not right to make it available, it is copyright protected. Please only use it for debugging purposes. Thanks!

    Edited 3 times, last by Hauke ().

  • Maybe better to Post a 10-20sec Clip not an entire recording. You can Cut it without recoding with TS doctor Trial Version for example.



    Edited 2 times, last by Nicolas ().

  • OK, put the first few minutes (300 MB) online (edited link above).

    Will try examples.


    Interesting... When I run the linked in video, i.e. the 300M excerpt which I just created using

    head -c 300000000 original.ts > part.ts

    I get playback controls! Also, when I use the demo video no prob, but with larger files I consistently have missing controls. What I will do now is create growing sizes of chunks of the original video and see where it breaks down...

    Edited 4 times, last by Hauke ().

  • Not sure if this helps...on estuary I only get rewind,pause and play with your recording...on silvo I get all controls..

  • Now I'm at a loss... I have recordings that are 1.4 GB and show no playback controls, but if I create a part as described above of a larger video even a 1.8 GB file shows playback controls. Anyone with an idea what in the original files can confuse the player?

  • The Only Thing I can think of is Metadata from tvheadend or fillbits in the original DVB Stream...