rpi4 continuity counter errors during file transfer

  • I'm using rpi4 2 GB with tvheadend,

    Today I transfered recordings from sd to ssd attached through USB3.

    During the file transfer I'm getting several continuity counter errors in tvh log and livetv shows artifacts and audio dropouts.

    Could this be improved?

    tvh log http://ix.io/2feX

    dmesg http://ix.io/2ff4

    Edited once, last by polo_joe ().

  • In this issue tvh isn't recording, just providing livetv.

    I will test if recording to usb attached SSD will improve the situation.


    dvb card - > USB2

    sharkoon xt duo 2 port dockingstation -> USB3

    If I start recording on dockingstation and start playback of this recording after some seconds I get the same errors in tvh.

    If I'm starting livetv and start filetransfer through ssh mc from first port on dockingstation to second port on dockingstation I get the same errors.

    So neighter recording to usb nor file transfer on dockingstation work.

    Could there be an usb issue on rpi4?

    Edited 2 times, last by polo_joe ().

  • Thanks for your support, much appreciated.

    I tried to connect dockingstation and dvb card to usb3.

    Unfortunately neighter playback during recording nor file transfer from and to dockingstation work without errors in tvh.

    • Official Post

    Running out of ideas but your dmesg log (at the end) showed a USB disconnect. Double check you cables and change if possible.


    1) A fresh install without any addons/customisation (bar TVH)

    2) Install the LE addon "system tools" and monitor the system with either nmon, htop to see I/O and memory usage.

    3) Check free memory withfree -h

    4) Check you USB ports, but adding a USB device and check dmesg for any disconnets

    5) Check your power supply and change if possible. Also check output of vcgencmd get_throttled if NOT 0x0 then you have issues.

  • Thanks for your suggestions:

    I changed usb cable to dvb card with no improvement.

    1) will take some time.

    2) htop section i/o ony shows "no perm" for reads an writes

    3) around 1 GB free

    4) dmesg doesn't show any disconnects http://ix.io/2fNl

    5) power supply should be ok, never saw a value other than 0x0

    Could it be, that dvb usb packets aren't processed in time, so tvh shows error?

  • Iridium

    today I started from scratch, only installed tvh and oscam

    started recording, after some seconds I started playback of this recording.

    in tvh log I see the same error as before.

  • Hello!

    Since LE 9 this also happens on X86 systems. If you Copy a File while watching live TV or a recording it will sometimes stutter or even stops for a Second.

    On a Pi this happens more often than on X86.

    It makes no difference If you have a fast PC with SSD, it is less but still you will notice it. The only way that i found out to Work around this or making the situation better is using a dedicated different device for your recordings or your system. It is like the copy process uses all, or more recources than before.

    Same Thing but only Kodi 18 related, when watching live TV a recording or whatever and you go to your Library or epg and you want to See detailed Info for a movie, tvshow etc. The Playback stutters and even Freezes.

    But as said this is Kodi itself die to Changes on Player Framework or Video playback method.

    Playback in Kodi 17 (LE8) was way smoother than it is in Kodi 18.



    Edited once, last by Nicolas ().

  • Since LE 9 this also happens on X86 systems. If you Copy a File while watching live TV or a recording it will sometimes stutter or even stops for a Second.

    I can't reproduce this on my Intel J4105 box. Tried to copy large files over LAN and record while watching live TV. No issues.