[8.2.3.1] LibreELEC 8.0 for S805

  • Just updated to latest, seems alot quicker than before, also no issues playing hd videos. Good work :)


    Sent from my ONEPLUS A3003 using Tapatalk

  • I just spend the evening trying to get this build installed to nand on my MXQ s805. All of my attemps failed.


    First, i wrote the image to sd. Booting from sd with toothpick method works fine. After enabling ssh, i ran the installtointernal command. The first attempt resulted in no errors. But after a reboot i only get "Android system recovery <3e>" showing "no command" error.


    After this, i tried the recovery install procedure with 7.0.3.3.a build. I installs fine, but after rebooting it freezes showing the libreelec logo.


    After this, i tried again install with "installtointernal", now with 7.95.beta.5a . Again i can boot from sd. But now this is wat happens:


    Backing up remote.conf...mount: mounting /dev/system on /tmp/system failed: Invalid argument
    umount: can't unmount /tmp/system: Invalid argument
    done.
    Writing kernel image...88+1 records in
    88+1 records out
    5781504 bytes (5.5MB) copied, 3.520047 seconds, 1.6MB/s
    done.
    Formatting SYSTEM partition...done.
    Copying SYSTEM files...mount: mounting /dev/system on /tmp/system failed: Invalid argument
    umount: can't unmount /tmp/system: Invalid argument
    done.
    Formatting DATA partition...done.
    Do you want to copy your user data to internal data partition? [Y/n] n
    All done! You can now continue using your LE system or type "rebootfromnand" to reboot from internal memory.


    Again tried 7.95.beta6, same result.


    To sum things up: i can do recovery with 7.0.3.3 but this won't boot LE. With 7.95.beta6 i can boot from sd but cant install nor boot from internal nand.


    Please help...

  • It looks like there's an issue with mounting system partition. Have you tried both MXQ and HD18Q builds?


  • It looks like there's an issue with mounting system partition. Have you tried both MXQ and HD18Q builds?


    I haven't tried HD18Q builds. Will go and test it tonight. Keep you posted.. Thanks for the advice.

  • Well is there any step-by-step instruction how to install on MXQ S805 (Android 4.4.2 preinstalled) instead Android??? Do I need to do something additionally to do that?? And did anyone tried Kodi Netflix addon(Flix2Kodi or anything else) and can say it's working??

    Edited once, last by kop524 ().

  • kszaq


    I took a screenshot of the font problem I mentioned earlier. You can see the white part of the text that shouldn't be there, this is just the home screen of the default skin. I don't know if it's a Kodi issue, a TV issue, or a problem with the box/build but here it is :D


    Edited once, last by rev6 ().


  • kszaq


    I took a screenshot of the font problem I mentioned earlier. You can see the white part of the text that shouldn't be there, this is just the home screen of the default skin. I don't know if it's a Kodi issue, a TV issue, or a problem with the box/build but here it is :D




    Is it like that everywhere you go in the menu or only on 'TV Shows'??


  • Well is there any step-by-step instruction how to install on MXQ S805 (Android 4.4.2 preinstalled) instead Android??? Do I need to do something additionally to do that?? And did anyone tried Kodi Netflix addon(Flix2Kodi or anything else) and can say it's working??


    You saying you want to install this over the android firmware?


    Sent from my ONEPLUS A3003 using Tapatalk

  • TV Shows was just an example. It's visible everywhere I believe.


    So IMO it is OS itself and it may be repaired in future releases but it's not 100% sure ;)
    BTW on MBOX MXQ that I have it's probably not possible to do toothpic but i'm not sure what is that about so if someone can explain it to me then maybe I will be a happy uesr of LE on my box.
    [hr]


    You saying you want to install this over the android firmware?


    Sent from my ONEPLUS A3003 using Tapatalk


    YES or at least alongside android :)

    Edited once, last by kop524 ().

  • Download the sd card creator software from here downloads – LibreELEC


    Then download the image file for your box from here 7.95.beta6


    Then open the sd creator software and click select file and add the file you just downloaded. Once its finish remove the sd card and insert it into your box with the power out. Insert a toothpick into the av port on the back (think its av port) and hold it in while inserting power plug back in and keep holding till it boots up and it should install it


    Sent from my ONEPLUS A3003 using Tapatalk
    [hr]
    By the way it wont actually install it will just boot from sd card, and when you remove the sd card it will go back to android


    Sent from my ONEPLUS A3003 using Tapatalk

    Edited once, last by Steve1987 ().

  • I haven't tried HD18Q builds. Will go and test it tonight. Keep you posted.. Thanks for the advice.


    Just installed the HD18 build. Installs perfectly. For whom is facing the same problem, this concerns the black "mxq" box with black logo. I'll attach a photo of the box. Even the remote works again with the HD18 remote file. The installtointernal copied it immediately.


    s805Kodi:~ # installtointernal
    This script will erase BOOT, SYSTEM, and DATA on your device
    and install LE that you booted from SD card/USB drive.


    The script does not have any safeguards!


    Type "yes" if you know what you are doing or anything else to exit: yes
    Writing kernel image...86+1 records in
    86+1 records out
    5650432 bytes (5.4MB) copied, 0.764111 seconds, 7.1MB/s
    done.
    Formatting SYSTEM partition...done.
    Copying SYSTEM files...done.
    Formatting DATA partition...done.
    Restoring remote.conf...done.
    Do you want to copy your user data to internal data partition? [Y/n] n
    All done! You can now continue using your LE system or type "rebootfromnand" to reboot from internal memory.
    s805Kodi:~ # rebootfromnand

  • Ok toothpick boot worked for me but is there a way to install it???


    PS. Unfortunatelly Flix2Kodi not working both on PC and Box

    Edited once, last by kop524 ().

  • Open up an ssh with putty, insert your box IP address, username is root, password is libreelec then type installtointernal and follow onscreen instructions


    Sent from my ONEPLUS A3003 using Tapatalk

  • Is there anyway to passthrough audio via HDMI? I can select passthrough but cant select the device, it will only passthrough the s/pdif...


  • Hello. Just one small doubt.
    There is a configuration under Settings/System/Display that is: Number of buffers used by grafic driver : 2 or 3. What is the recommended value to be used in our boxes?
    I am running 7.95.beta6 MXQ version on my MXV S805 box.
    Thanks!