[8.0.2e] LibreELEC 8.0 for S905/S905X

  • I have one questin about Kodi and Gui behavior:

    If i'm watching LiveTV and i press the "back-button" on the remote control, the video freezes about 0,5 seconds.

    Is this a bug in this Amlogic Builds, or is this due to limited resources of 905(x).


    Thx

  • I think I got a problem. Not sure.


    When I try to play a movie I dont get audio. Youtube Addon works fine though.


    Code
    Acoustic : English DTS 1509Kbps 6ch


    Is it hardware related? Using ARC to Home Media Player.


    another one:


    Code
    AUDiO: 384 Kbps AC3 5.1



    fix: Weird. I changed Number of channels from 2.1 to 2.0 and now it works. I have a subwoofer though ??

    Edited once, last by DMC_12 ().

  • I think I got a problem. Not sure.


    ....


    fix: Weird. I changed Number of channels from 2.1 to 2.0 and now it works. I have a subwoofer though ??

    Try enabling audio passthrough in expert mode in the settings. If you are using a receiver for surround sound etc this is what you want to let the receiver do the decoding work. This is just a general KODI setting to be aware of and you can pick what capabilities your AVR is capable of decoding but it might also fix your audio issue.

  • Question, do these builds work with HDMI-CEC (for remote control of KODI) out of the box or is there some magic that needs to be done?


    Thanks.

  • It's out of the box, but you can check and fine tune all the CEC setting in settings, input, peripherials.

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V
    pel.hu

  • Has anyone had problems upgrading to 8.0.2d?


    I tried to upgrade as per normal, (tar file with device tree in upgrade folder), reboot, and all I got was a black screen after reboot. I was running 8.0.2b from nand before the upgrade. I have an MXQ Pro 4k S905.


    I brought the box back to life, flashed 8.0.2d to a USB and everything worked fine again with the exception of the remote. Uploaded remote.conf file and got that working again. Tried to installtointernal again and got the black screen again. I was able to boot it from the USB again, but I'd prefer to be on nand as it's a little more responsive.


    Any thoughts or suggestions would be appreciated. I may just go back to 8.0.2b as that was the last know working version for me.

  • Hi.

    Not sure it matters, but anyway, the device is Khadas VIM 2/16.

    I made the following (mistake).

    Copied my device's device tree file (from the download section) to Update folder of my elec and rebooted it.

    Now the device wouldn't boot. LibreElec is installed into internal memory of the device.

    The same happened with system installed on SD card. I solved it by popping the card into PC and copying the dtb.img into system directory and thus solving the problem.

    Is there a way (by SSH or somehow) to copy the dtb.img into system folder of the device's internal storage?

    Thanks.

  • Is there a way (by SSH or somehow) to copy the dtb.img into system folder of the device's internal storage?

    Code
    dd if=/dev/zero of=/dev/dtb bs=256k count=1
    dd if=dtb.img of=/dev/dtb bs=256k