Failed to start xorg help

  • I ran this with LE version 9.2 for amd, intel and nvidia generic version. Is there another version should I try?

  • What's the model name of the MacBook? .. and what GPU does it actually contain?

  • Model Identifier: MacbookPro16,1

    Processor:2.3 GHz 8-core intel core i9

    Ram: 32 GB

    Hyper Threading enabled

    GPU: Built-In. Intel UHD Graphics 630 and PCIe AMD Radeon Pro 5500M with 8 gb ram

  • Code
    echo "i915" > /storage/.config/udev.d/blacklist.conf && reboot

    See if blacklisting the Intel driver allows the Radeon GPU to be detected, and if that doesn't work, see if blacklisting "amdgpu" or "radeon" works instead. If neither works it's probably a missing PCI device ID in one of the drivers. That's my guess (and it's a guess).

  • udev.d folder was not available on the specified path. So, I created that directory and tried with i915, amdgpu and radeon. it didn't work still xorg server failed to start. should I try anything else?

  • Code
    echo "i915" > /storage/.config/modprobe.d/blacklist.conf && reboot

    ^ right path this time

  • mglae


    first I tried with i915 then radeon both of them didn't work. I pasted code from syslinux.cfg


    please let me know if I'm missing something


    SAY Wait for run mode to start automatically in 5 seconds...

    SAY

    SAY Options

    SAY =======

    SAY installer: permanently install LibreELEC to HDD/SSD

    SAY live: boot LibreELEC using RAM for temporary storage

    SAY run: boot LibreELEC using this USB memory device for storage

    SAY

    DEFAULT run

    TIMEOUT 50

    PROMPT 1


    LABEL installer

    KERNEL /KERNEL

    APPEND boot=UUID=2311-2503 installer quiet tty vga=current


    LABEL live

    KERNEL /KERNEL

    APPEND boot=UUID=2311-2503 live quiet tty vga=current


    LABEL run

    KERNEL /KERNEL

    APPEND boot=UUID=2311-2503 disk=UUID=7316a96d-76f4-4b28-97e3-f77cabcb70ff tty portable quiet initial_blacklist=i915_init

    >

    ---------------------------------


    SAY Wait for run mode to start automatically in 5 seconds...

    SAY

    SAY Options

    SAY =======

    SAY installer: permanently install LibreELEC to HDD/SSD

    SAY live: boot LibreELEC using RAM for temporary storage

    SAY run: boot LibreELEC using this USB memory device for storage

    SAY

    DEFAULT run

    TIMEOUT 50

    PROMPT 1


    LABEL installer

    KERNEL /KERNEL

    APPEND boot=UUID=2311-2503 installer quiet tty vga=current


    LABEL live

    KERNEL /KERNEL

    APPEND boot=UUID=2311-2503 live quiet tty vga=current


    LABEL run

    KERNEL /KERNEL

    APPEND boot=UUID=2311-2503 disk=UUID=7316a96d-76f4-4b28-97e3-f77cabcb70ff tty portable quiet initial_blacklist=radeon_init

    >




    after checking the above, i tried with chewitt

    echo "i915" > /storage/.config/modprobe.d/blacklist.conf && reboot


    no luck there either.

  • Thank you!


    i tried with initcall_blacklist=i915_init and initcall_blacklist=radeon_init it didn’t work.

    Then I took the kernel 5.5 build from the 618 link you provided LibreELEC Testbuilds for x86_64 (Kodi 19.0)


    i’m getting different error now when I try with my MacBook Pro. I tried the initcall_blacklist param on this updated alpha version too. Still got the same error. I attached the photo for your reference.

    Thanks for your help.

  • I'm getting out of ideas, just a few thoughts:


    - The 5500M driver is "amdgpu", to blacklist it use initcall_blacklist=amdgpu_init (or initcall_blacklist=amdgpu_init,radeon_init)


    - You can add textmode to the kernel parameters. On successful boot you get a text console and i.e. can use dmesg and journalctl for further research.


    - Check apple community HW forums if there is any linux support today for the MacBook.

  • I can't get that worked. will update if I find any other way. I bought RPI 4 to try on for now. RPI 4 is not showing my avr name in system/audio/audio output device. is there a way to make it show my receiver name there? thanks!