[unoffical] LE-9.2/9.80-Images for RK3229/RK3228

  • No you dont apply any update from SD card, if that happens that you see the normal android recovery (happend to me before) that means you probably dont have a correct device tree file on your SD card that fits your android box.

    Can you give me some extra info about your box ? maybey I can point you in the right direction. (foto, specs according to supplyer, screenshot android hardware info, ...)

  • ive got the mxq-4k box rk3229 1g/8g. mxq-4k 20160325 board. im currently using the mxqpro image that seems the most stable on the box, memory usage is currently 14%.while stream playing after 4hours of use

    wifi not working on any of the images that i tried. i put the remote files in the config folder but cannot switch on via remote - just navigate and switch off

    also tried the v88mars,v884k,v88 marsII images but the cpu tempearture went to 90degrees and memory usage went to 40% while leaving the same stream on at 720p

  • Hello,

    Where could I find your builds again ? I want to test the one with kodi 18.9 , your previous one's worked nicely :)

    I think you gave me a link previous time, but I dont know if you have a dedicated spot somewhere now for your builds ?

    Thank you,


    EDIT : I found your google drive link, I think I found the new builds with KODI 18.9 , I will let you know if they work, thank you in advance.

    Edited once, last by Hansie ().

  • As promised I tested it and everything seems to work except one addon that does not work

    Its an addon to watch live TV from our cable provider.

    when I start it, I get a kodi message "errors occurred, please check log"

    Log part from this Yelo TV addon

    It installed fine and got its dependency's fine, Normaly at the first startup it should ask to install the Wildvine thing to be able to play DMR content, but it does not do this :(

    Any help would be appreciated,

    Today I also installed the latest coreelec with Kodi 18.9 on my other box with a S905 chip, and on this box I was able to install everything (also this addon and wildvine) so I dont think it has to do with kodi 18.9 compatibility of the Yelo TV addon.

    thank you in advance,


    P.S. I am using your A8 image, this worked fine with your previous build with Kodi 18.8 (including the addon)

    EDIT : You can fully disregard this mail, aperantly about an half hour after I tested the telenet yelo app with the coreelec box, the entire telenet yelo / webmail, ... service went down in the entire country for the rest of the night, so afcourse that was the reason I could not get the yelo play app to work on the libreelec box !!!! how unlucky can someone get :)

    So I can confirm Ilmich , everything working great on my MXR4K box using your A8 image (even the remote worked out of the box :) )

    Thank you,

    P.S. why is "nation-wide" a censored word on this forum ????

    Edited once, last by Hansie ().

  • Hi ilmich!

    I'd love if you could make the build for mxq4k, I tried to build it myself but I am not able to get it, if I get some time, I'll post the problems I've run into.

    Very appreciate it!

    Best regards!


  • Hello,

    If your MXQ4K box is the same as mine than it will have a S905 chip, these particular builds from Ilmich are for the Rockchip devices (like my MXR4K

    I dont know if Ilmich has builds for SMlogic devices, but there are more than enough on this forum (also if you have a look at the guys over at coreelec they ONLY build for SMlogic devices, and are good at it)

  • Hello,

    If your MXQ4K box is the same as mine than it will have a S905 chip, these particular builds from Ilmich are for the Rockchip devices (like my MXR4K

    I dont know if Ilmich has builds for SMlogic devices, but there are more than enough on this forum (also if you have a look at the guys over at coreelec they ONLY build for SMlogic devices, and are good at it)

    Hi Hansie!

    Thanks for your recomendation, but mi box is Rockchip 3228 as it seems. The only thing I really miss is the WiFi, mine is ESP8089 chip. I'm not really very proficient in building software, but if someone would try to add support to it, I'd very appreciate it. In the meantime, I will begin trying to build by myself if I have some spare time.



  • Hi juliomm64,

    I've uploaded the image of (quoted from 1st post)

    • MXQ 4K Pro, RK3228A, DDR3, oviously deliverd with different wifi types - some will work, others not

    I've also removed oldest image (kodi 18.8) in order to reduce space on my gdrive.



  • Hi Michele!

    Very much appreciate it!

    I'll test it tomorrow sunday, and comment out success or any issue

    Best regards


  • I'm needing help. I'm new in this kind of tech world. May I know what (most compatible)ROM I can use for this?

    Hello Hiru,

    If that sticker is correct and it has a rockchip R3229 chip than I would go to Ilmich his link.

    Ilmich's images

    and try the HK1 mini image he has there,

    Afcourse your box might have more or less RAM and different wifi, we can not see this from that sticker, so it will be a bit trial and error to find the right one.

  • Hi,

    I've been trying out most of the rk3229 images on a SD card and all tried ones behave same way on my android tv box (r-box plus 4k rk3229 2GB 16GB): the box boots fine , I am able to connect to wi-fi and connect via ssh to the box.

    Everything seems right except the Module Drivers addon/section which is empty. ("no driver modules found!")

    Any idea what might be wrong ?

    Anyway , good job with creating these rockchip images and thanks a lot!

  • hello, maybe this is slightly off topic but i notice that some people have had a problem getting their remote control to work with the various images in this thread.

    the rockchip IR input drivers emit linux input events directly to the /dev/input/eventX devices, without using lircd or eventlircd so most of the step-by-step directions for setting up a remote control won't work on rk322x systems.

    here is a link describing how to setup a remote control for rockchip:

    TB-RK3399ProD wiki

    basically, you need to connect to the system and get a shell prompt from the console or over ssh

    enable IR debug output

    echo 1 > /sys/module/rockchip_pwm_remotectl/parameters/code_print

    then press all of the buttons on your remote

    use 'dmesg' to see all of the debug output and make a note of the user code and data code for each key press

    then, you need to edit the flattened device tree for your system to add the remote control mappings..

    shutdown your tv box and put the SD card back in a regular computer

    use the linux device tree compiler to decompile the *.dtb file on the root of the SD card to a more readable dts file

    edit the mappings in the dts file--

    each remote type seems to have a user code, so find the ir_key section corresponding to your remote's user code or create a new one.

    the values in rockchip,key_table are pairs of remote data code followed by linux input event code..

    so make a new table using the data codes that you wrote down from pressing your remote buttons and the corresponding linux input event codes from here:

    linux/input-event-codes.h at master · torvalds/linux · GitHub

    then use the device tree compiler to compiler your work back into a .dtb file, copy it over the old dtb file on the SD card.

    hope that helps you or someone you love.

  • Hey hi! I'm having a problem with Retroarch crashing and not working on my V88 4k, do you have a link of your distro merged with Lakka? Thank you very much

  • Hi All, Can someone please point me in the right direction, it's my first time attempting to flash one of these TV Box units.
    I have a Scishion V88 4K, on the pc board its printed: MX4N-V02 2016-06-27 and there is a sticker on the board that shows: MX4N 8G/1G ZXD 2017-02-09 WW16120089
    I went to the downloads page and saw the bootable media creation tool, but i did not see the recommended "V88Mars LibreELEC-RK322x.arm-9.2-devel-20200301143855-b58333a-rk3228b-v88marsII.img.gz" firmware to download suggested by another user earlier in the thread.

    Are there any issue that i need to take precaution off (besides the UHC memory cards)