UPNP-Service is not correctly running on Raspberry Pi 4B

  • Hi @ all,


    I'm using Libreelec 9.2 on my new Raspberry Pi 4B in combination with my Synology NAS as my mediaserver.

    The Pi is connecting to this media by UPNP.

    Every Time, when I boot the Pi and try to connect to my NAS, KODI says, that there is no network connection to the NAS.

    Then I go to the settings menu, section services, uncheck and check the option for activating UPNP. Now I can connect to my mediaserver.


    Thanks in advance for your support!

  • Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem.

    Note: Full logs only. No partial or modified logs.

    Do not post your logs directly into the forum, use pastebin.com and post the link.
  • Every Time, when I boot the Pi and try to connect to my NAS, KODI says, that there is no network connection to the NAS.

    Enable the "Wait for network" option in the LibreELEC Settings Add-on, set it to 20 secs or so.


    Using UPnP is not the most ideal file protocol when playing videos with Kodi.

    SMB and NFS are more direct file protocols with less overhead.

  • Thank you guys for your fast reply!:thumbup:

    I've posted the debug log under


    I've also enabled the "Wait for Network" option, now it works without restarting the UPNP-Service.

    Thanks for the tip to use SMB, I will try this option too!