Unofficial LE for RK356x RK3328\RK3399 RK3588(s)

  • chewitt  balbes150

    These are the tests that I have carried out with my RK3318 (HK1 SUPER):

    To boot any Libreelec image on sdcard, you must always first install any Armbian image in internal memory with the multitool. If we have the memory with Android or the internal memory erased, Libreelec does not start.

    In LE10 official Libreelec versions you have to inject trust.img, in LE11 development versions of Balbes150 trust.img is already included.

    I have to use the DTB rk3318-a95x-z2.dtb and everything works great:

    Video decoding HW --- OK

    Led --- OK

    Ethernet --- OK

    SSH and SFTP --- OK

    Remote control --- OK

    WIFI or Bluetooth --- NO. (Attached log and dmesg. I also attach photos of the hardware).

    Installing Libreelec in internal memory makes the tvbox brick. With Multitool, Armbian and bridge on the board it is easily unbrickeable. I haven't tried this yet:

  • Hi all and thanks for your work. I want to share my experience with different images botting from SD in my Neox X7:

    LibreELEC-ARMv7.arm-11.0-devel-20210818064457-34fd57d-rk3188: boots correctly, wifi working with an USB dongle, excelent video play, can´'t connect via ssh (yes I can) , installation to EMMC from Kodi menu not working.

    LibreELEC-ARMv7.arm-11.0-devel-20210920100043-8bd19d9-rk3188: does not boot

    I haven´t found any more recent images for RK3188, any plan to release newer ones in the future?

    Thanks again for your time and dedication.

    Please, could you provide me with the link of the img that does start and indicate the dtb you use?

  • Please, could you provide me with the link of the img that does start and indicate the dtb you use?

    I have just checked that the img has been deleted from the folder in Yandisk where it used to be. I guess balbes150 needed more space for the recent images he has been upoading since August. DTB used was rk3188-ugoos-ut2.dtb (defined in extlinux.conf)

  • Acabo de comprobar que el img se ha eliminado de la carpeta en Yandisk donde solía estar. Supongo que balbes150 necesitaba más espacio para las imágenes recientes que ha estado subiendo desde agosto. La DTB utilizada fue rk3188-ugoos-ut2.dtb (definida en extlinux.conf)

    yes, that's why I asked for it. Don't have it downloaded to your pc?

  • Hello chewitt and balbes150

    I wanted to tell you that I have news about Libreelec on my HK1 Super device and at the same time ask for your help.

    I have managed to run Libreelec on a sdcard on my RK3318 tvbox with almost 100% effectiveness. These are the updated data:

    As before, to boot any Libreelec image on sdcard you always have to install any Armbian image in internal memory first with the multitool tool. If we have the memory with Android or the internal memory erased, Libreelec does not start.

    In this case I am using official LE11 community versions.…f3241-a1.img.gz

    And now I use the following Armbian DTB rk3318-box.dtb, attached to this post. I must also use the /storage/.config/firmware/brcm folder with the driver for WIFI to work, also attached to this post.

    Video decoding HW --- OK

    Led --- OK

    Ethernet --- OK

    SSH and SFTP --- OK

    WIFI --- OK

    Bluetooth --- NO. (I ask for your help to fix this and I am attaching a new log and dmesg. Pictures of the hardware can be seen in my previous post).

    Installing Libreelec in internal memory makes the tvbox brick, I would like to fix that.

    I wonder if with this data they can support this RK3318 (HK1 Super) tvbox or add the DTB and WIFI / Bluetooth driver to future images.

    Thank you for your work, it is excellent and wonderful.

  • At a quick scan I can’t see hci, Bluetooth, or bt in the kernel dmesg. Is the DTB file enabled to support a Bluetooth device?

    Hello heitbaum
    I really don't know, the DTB file was not made for me. I only tried to use this Armbian DTB in Libreelec and everything works except BT.

    In Armbian BT does not work either.


  • A bit of googling and it seemed these are the details of the chip (potentially). Next is getting a dts/dtsi… test …

    • WiFi/Bluetooth - unnamed dual-band IEEE 802.11 a/b/g/n Wi-Fi/Bluetooth 4.0 marked HK5230;
    • This is a 2011 IEEE 802.11 a/b/g/n Wi-Fi/Bluetooth 4.0 module - Ampak AP6330 on the BCM4330 chip.
  • Desafortunadamente la nueva imagen no arranca en mi Minix X7, mismo error que con la anterior. Captura de pantalla adjunta.

    I hope I'm not breaking any forum rules...…iew?usp=sharing

    I have tried this version on Minix Neo x7 (RK3188) and it works (the current ones in yandex are not). The ethernet card does not work, nor the internal wifi, I had to use a wifi usb. I leave here the dmesg in case it helps to support it:

    I have created a remote to be able to use the one that came with the tv box (I attach it).

    Some facts about ethernet:

    [ 1.336009] rockchip_emac 10204000.ethernet: ARC EMAC detected with id: 0x7fd02

    [ 1.336017] rockchip_emac 10204000.ethernet: IRQ is 37

    [ 1.336054] rockchip_emac 10204000.ethernet: MAC address is now 56:f5:ff:64:71:6a

    [ 1.468098] rockchip_emac 10204000.ethernet: connected to Generic PHY phy with id 0xe000

    [ 11.538234] rockchip-pinctrl pinctrl: pin gpio3-23 already requested by 10204000.ethernet; cannot claim for serial0-0

    [ 14.641581] rockchip_emac 10204000.ethernet eth0: Link is Down

  • I have the same results with that img in my Neo 7. Thanks for the file to use the original IR remote control!

  • Quick question, I just found my old Tronsmart MK908 (mk3188) and in the basement and fired it up... Is it garbage or will these builds work?


    There is a dtb for your device. if you try the img whose link appears a few posts further back it should work.

    Edited once, last by havhav (November 30, 2021 at 12:55 PM).

  • can you make it easeir to boot from sd or usb and will it work with yx_rk3328_8d4_v1.0 (CPU is rk3318)
    my wifi sdio is 0x4334 (hk6334q) Probably based on SP6334q but with some alternate mode missing or undocumented...

  • how do i get my bluetooth working?

    i already added the brcm firmware for 4330 and 4334 sdio on rk3318 and the wifi works, but it says bluetooth is turned off, and there's no option to turn it on...

  • Here is the proper file for 4330 and 4334