Some settings are not saved persistently

  • Hi,


    Some months ago I set the audio output to PULSE/Bluetooth. I was testing something. As the results were not satisfying I switched back to HDMI. Now whenever I reboot the Raspberry, the wrong setting "PULSE" is restored.

    Also after a reboot the audio replay mode is set to random even if before it was track order.


    My system is LibreELEC 9.02 running on a Raspberry 2.


    Any idea what might be wrong?


    Joesse

  • Manually edit your GUI settings (nano /storage/.kodi/userdata/guisettings.xml).

    Edit two lines this way:

    Code
    1. ...
    2. <setting id="audiooutput.audiodevice">PI:Both</setting>
    3. ...
    4. <setting id="musicplayer.autoplaynextitem" default="true">true</setting>
    5. ...

    Reboot.


    PS:

    If this won't fix it, edit another line (it's part of the expert audio settings, not sure whether you touched it):

    Code
    1. <setting id="audiooutput.config" default="true">2</setting>

    Edited once, last by Da Flex ().

  • Ok I tried that.

    I edited guisettings.xml as you suggested and did a reboot, but again there was configured PULSE.

    So I looked closer. I set audio output to HDMI. guisettings.xml was changed at 22:50.

    I shut down the Pi at 23:00 and booted at 23:04. guisettings.xml was changed at 23:04, but still read <setting id="audiooutput.audiodevice">PI:Both</setting>. I then looked at the settings via GUI (Settings - System - Audio). Here "PULSE" was displayed.

    I left the screen without changing anything. Now guisettings.xml was changed (23:08) and read <setting id="audiooutput.audiodevice">PI:Both</setting>


    So the wrong setting is saved at yet another place and restored after boot while guisettings.xml still holds the correct value. Only after editing the settings guisettings.xml is adjusted. Do you (or anybody) know, where this "yet another place" might be?

  • I set audio to the desired value HDMI and switch on logging.

    I do a restart.

    After kodi is back, I go to settings and set audio to HDMI again.

    I shut down the system.

    The log is here: http://ix.io/22nl

  • The log shows that after startup the RPi is outputting audio to HDMI. But you seem to have a plugin "service.bluetooth-audio" installed which is then switching audio output to pulse. Uninstall that addon and everything should be fine again.


    so long,


    Hias