[solved] impossible to add NFS source from libreelec interface

  • Hi,


    After a reinstallation with the last libreelec version (before i had a double boot with ubuntu and an openelec upgraded to libreelec), i found impossible adding nfs sources as i used to, simply using "add source" - "nfs"

    It worked perfectly with my previous installation, and the NFS server works perfectly as i use it from other linux machines.


    I finally got access to my nfs server adding nfs mounting scripts with ssh as described here https://kodi.wiki/view/nfs#nfs_sharing_from_linux


    Actually, i still didn't understand the reason why the previous behaviour of simply adding nfs source from libreelec interface didn't work...:/:S


    This post is to share the solution i used, and if it's possible, also to get an explaination, or opening a bug thread


    Good night all.

  • Doesn't work for me on version 9.1.501 on an RPi4, tried nfs & cifs and windows box, linux box and MBL box. Feels like a bug - giving up!

  • SMB and NFS do not work via the Add Video browse function. SMB browse has not worked for a while.


    NFS is throwing an error:

    2019-11-01 10:16:02.813 T:3011928080 ERROR: GetDirectory - Error getting nfs://

    2019-11-01 10:16:02.813 T:3011928080 ERROR: CGUIDialogFileBrowser::GetDirectory(nfs://) failed


    Related to: Github


    However, both work if you enter the details directly.

    i.e.

    smb://<host-ip>/<Samba Share>

    or

    nfs://<host-ip>/<export details>


    However: The preferred method is mentioned Here

  • SMB browse still works fine .. but as designed, and it's designed (by Microsoft) around SMB1 networks and these days everyone is running SMB2+ which doesn't support browsing.