Hyperion addon does not work with inputstream.adaptive (Netflix etc.) with Pi4

  • quick update:

    i can now safely say that my problem of losing HDMI signal in 25fps videos is connected with showing the progress bar during playback with hyperion active.

    Using the settings suggested by hias, playback per se works. but as stated above, as soon as i press any button that pops up the progress bar , HDMi signal will be lost after a second or so. i can reproduce this with any kind of 25fps video. Due to copyright reasons i am reluctant to upload anything, but i checked it with some youtube video with the same results (HIS DARK MATERIALS Trailer (2019) - YouTube -> downloaded as mp4).

    i was also mistaken that the machine doesn't come back up if i force it to reboot... it just takes about 5 minutes (no kidding) to be back up in this case. this is on a RPI4 4gb connected to a LG Oled C9 with 106 APA102 LEDs.

    any ideas would be much appreciated

  • I tried playing the linked youtube video but I haven't been able to reproduce the issue here. Video info showed that the 1920x1080 25fps stream was played and tvservice -s showed that video output was 1920x1080p50.

    I've tested both with LE 9.2.0 and the upcoming 9.2.1 release (should be out soon) with Estuary and Confluence skins. All overlays (progress bar, info) showed fine and the video signal didn't drop out.

    Please post a debug log, that should give some hints if some of your settings are different to what I'm using here.

    PS: reboot taking a couple of minutes when you hit the no signal issue is quite normal, I also get that here (the system has to run into a couple of timeouts until it's able to shut down).

    so long,


  • No changes regarding to Hyperion on RPi4 in this release.

    Regarding crashes: have you overclocked your RPi? If yes, drop the overclock settings, you may need to set different values due to changes in the firmware.

    so long,


  • HiassofT

    Thanks! Yes, was 2 Ghz overclocked.

    Diable and iupdate was fine ;)


    wit this it works fine (after update 18.6)

    # Ambilight Modul aktivieren


    # mehr USB-Power


    # Overclock

    # over_voltage=4

    # arm_freq=2000

    # 4k Ausgabe



    Overclocking is working with 190 Mhz - LOL !

    With LE 9.2.0 - 2000 Mhz OK

    With LE 9.2.1 - 2000 Mhz Kernel error

    With 1950 it works ok now.

    Edited 3 times, last by JohnWayne111 (March 12, 2020 at 11:35 AM).

  • You could try increasing over_voltage a bit (to 5 or maybe 6) but in general it's very hard to give any recommendations as the achievable overclock values highly depend on the silicon in your RPi and also may change with different firmware versions.

    So, you have to test on your own what works on your RPi.

    so long,


  • JohnWayne111

    did i get that right , you solved the issue with the RPI4 losing HDMI signal at 1080p 25fps by overclocking the machine?


    so i activated debug logging and started playback of the aforementioned file via file explorer but now kodi will not even start playback anymore but immediatly drop the HDMI signal. what's weird is that after disabling debug logging again, the problem still persists. So it is not as it was before where it would only crash if i called up the status bar but instead will lose signal immediatly upon refresh rate change / starting playback. Interestingly hyperion still does its thing once the screen goes black and kodi is still playing the file.

    anyway here is the debug log. couldn't find anything interesting in there though (seems pretty confusing too tbh, esp considering the weird time stamps). Maybe you could have a look at it. cheers


  • The debug log doesn't show you playing any file - so doesn't help much. Please try again and when the screen goes black ssh in and run "pastebinit /storage/.kodi/temp/kodi.log", then post the URL.

    I noticed you have the RPi VNC server installed, please disable or uninstall it, it uses the dispmanx grabber as well and might interfere.

    BTW: Enable "wait for network" in the LE settings will fix the timestamp issue - kodi is starting before the network connection is up and at this point it didn't get the correct time from the NTP servers.

    so long,


  • I spent some time trying this again... results in my RPI4 2Gb LE 9.2.1 with a 1080 Samsung TV:

    Using external grabber (this is the workaround I am using since I get my RPi4):

    - hyperion works OK with all videos both local files and streaming ones, from all available platforms (youtube, netflix, amazon, hbo...).

    Switching my hyperion.config file to "normal"/internal grabber (best hyperion performance and colours accuracy):

    - hyperion works OK with all local files.

    - most streaming platforms work OK: youtube, vimeo, hbo, amazon.

    - Netflix is still a pain in the ass... when I play ANY video file the screen goes black and "No input signal" appears in my TV. If I stop the file the screens comes back. I tried changing some parameters in hyperion.config file as @HiassofT suggested, so if I change internal grabber's width/height from 64 to 256 and I try to play any netflix file, hyperion seems to work OK but when UI graphics are displayed (progress bar, notificacions, subtitles...) screen starts to flash (like in the video I posted some weeks ago). I tried increasing those values to 512 and it seems to work OK even using subtitles and when any UI element is present.

    So my doubts are the following:

    - What perfomance impact will have this increase in hyperion.config file for my RPi?

    - Will any overclock setting will help to decrease those values a bit? (here is my config.txt)

    If any log or kodi/libreelec settings are needed I will post them.


  • In my opinion all 1080p with SW Decoding and a framerate over 24 Hz will end in frame drops.

    In addition to that ... i try a local file H265 with 60 Hz and internal grabber - same signal drops! If i change to external grabber - no problems!


    But let me pls know if you have a workaround! I will test it too

  • In my opinion all 1080p with SW Decoding and a framerate over 24 Hz will end in frame drops.

    In addition to that ... i try a local file H265 with 60 Hz and internal grabber - same signal drops! If i change to external grabber - no problems!


    But let me pls know if you have a workaround! I will test it too

    try increasing internal grabber's width/height from 64 to 512.

  • HAHA NICE !!!! It works in my case !

    Set the settings from 64 (default) to 512 all netflix videos working finde with internal grabber.

    try also 4k 60 Hz videos - this will not work.

    I also try 1024, 2038, 4096 settings. Still buggy with 4k 60 Hz.

    But - more important - that now netflix works with 1080p :)

    THX A LOT!