RPi4 Composite out not working

  • Hi, I have installed LibreELEC (official): 9.1.501 (RPi4.arm) on Raspberry Pi 4. Everything seems to bee working on hdmi output. Then I want to connect my RPi4 to old CRT TV. There was no output at all. After reading documentation Video options in config.txt - Raspberry Pi Documentation i set this in config.txt


    mount -o remount,rw /flash

    nano /flash/config.txt

    enable_tvout=1

    sdtv_mode=2

    mount -o remount,ro /flash

    shutdown -r now


    Now libreelec boots with rainbow boot screen on composite output and than black screen. But Libreelec boots. I can ssh to it.


    So I do some research and find out that official raspian has similar issue and probably it was solved few days ago:

    Pi 4 - Terrible performance with enable_tvout=1 · Issue #1223 · raspberrypi/firmware · GitHub

    Lakka on RPi4 composite output bootloop · Issue #743 · libretro/Lakka-LibreELEC · GitHub


    Anyone can help me resolve this issue in Libreelec?


    Thank You.

    Files

    • dmesg.txt

      (30.32 kB, downloaded 16 times, last: )
  • I'm having a similar issue with 9.1.501 in a RaspberryPi 3B. If I set sdtv_mode=2 on the config.txt I get the "LibreELEC" splash screen, but never see the Kodi splash screen or the UI. SSH is available and I can edit the config.txt.

    If I set sdtv_mode=0 or comment out the sdtv_mode line, I see Kodi's splash screen and interface, but mode is set at [email protected] (thankfully this CRT is PAL, but multisystem on some inputs).


    Going back to 9.0.2 runs into the bug where screen overscan compensation ("video calibration") is lost after reboot (that's why I was trying 9.1.501).

    Going back to 8.2.5 leaves some addons not working.


    I don't think it's a bootloop because I only see the LibreELEC splash screen once and the SSH connection doesn't drop. Sorry I can't provide a log right now; what information do you need and how do I get it?


  • Thank you for posting something like this

    Edited once, last by Bethany2 ().

  • A couple of weeks ago, I tried the latest nightly at that time and the problem continued.


    With sdtv_mode=2 I get the new animated LibreElec splash screen, but as soon as Kodi loads, the screen goes blank (I never see the Kodi splash screen)


    With sdtv_mode=0, everything loads, but I'm running NTSC on a PAL TV.


    I'm attaching the debug logs:


    log-2019-10-06-15.28.41_sdtvmode2.zip

    log-2019-10-06-15.38.43_nosdtv.zip


    edit: drat, only realized now that this a thread for the RPi4, I'm on the Rpi3. This could be unrelated. Should I open a new thread?


    edit 2; I don't think I'm allowed to post many lines of logfiles, but after comparing both boot events, with sdtv_mode=2 the video mode is preceded by two DEBUG lines and later something doesn't initialize on the GPU - instead of loading resolution 16, a lot of DEBUG statements follow NOTICE: EGL_CLIENT_EXTENSIONS = NULL. With no sdtv_mode directive, after that notice follows NOTICE: Checking resolution 16 and the video system is initialized.

    Edited once, last by TJSilva: Added Mark I eyeball comparison of both boot events. The most complete logfile (that has both boot events one after the other) is the nosdtv.zip ().