[7.0.3.3d] LibreELEC 7.0 for S805

  • Bugfix release:
    7.0.2.2 7.0.2.2


    Commits from 7.0.2.1 to 7.0.2.2: Comparing 7.0.2.1...7.0.2.2 · kszaq/LibreELEC.tv · GitHub
    Kernel commits from 7.0.2.1 to 7.0.2.2: Comparing 5df008c...058e38b · kszaq/linux · GitHub


    Changelog:

    • fixed reading MAC address for devices with zeroes in eFuse
    • fixed updating from img.gz for NAND installations (this fixes updates from 7.0.2.2 and newer)


    Known issues:

    • V3_1 board cannot wake up from suspend/power off by pressing remote power button (u-boot bug)

      • you can now work this around by adding echo Y > /sys/power/wake_lock to autostart.sh - this would make your box not suspend and only turn off HDMI signal instead
      • you should note that with wake_lock enabled, your device is working all the time - e.g. pressing a keyboard button results in key press in Kodi that you cannot see!


    • 29.97 progressive videos may stutter
    • power LED on not officially supported boxes may not work as intended (too many boards to support them with a single build)
    • no HD-Audio passthrough and multichannel audio output
    • DVB support is experimental, some USB DVB tuners don't work at all
  • kszaq  
    Just had a friend drop off an all black MXQ s805 for me to show him how to flash
    LibreELEC.
    I am not going to do it as i am not sure about the 8GB eMMC FLASH instead
    of NAND in this box. I haven't seen this before in All Black MXQ's
    Is it safe to flash. I'm not sure eMMC is supported in your builds ??
    I will wait before doing it.
    Cheers.

    Edited once, last by kostaman ().


  • I am not going to do it as i am not sure about the 8GB eMMC FLASH instead
    of NAND in this box. I haven't seen this before in All Black MXQ's
    Is it safe to flash. I'm not sure eMMC is supported in your builds ??


    Yes, there are drivers for both eMMC and NAND internal flash. I have devices with both and it works. Another thing is that a lot of sellers advertise eMMC flash and in reality the box has NAND flash inside.


    If you want to be sure that it will work correctly, first run LE off SD card (that's what I recommend doing with every new box) and try to mount and list system partition over SSH:

    Code
    1. mkdir -p /tmp/system
    2. mount -o ro /dev/system /tmp/system
    3. ls /tmp/system


    If you see file list after last command, it means that LE should work after installing on internal memory.
    [hr]


    So no real need to push this update? V3_1 board. It's just a patch for wrong mac address that will be migrated to the next update you release anyway? My mac is correct atm [emoji3]


    The fix is included in 7.0.2.2. If you don't have issues with MAC address, there is no need to update.

    Edited once, last by kszaq ().

  • LibreELEC (community) Version: 7.0.2.2LibreELEC:~ # system-sh: system: not foundLibreELEC:~ #


    kszaq
    I installed SD card Version. Toothpick method it went into factory recovery screen. Chose reboot and the box booted into
    LibreELEC after that.
    All working really fast.
    Pressing power button on remote does a clean full power off.
    Choosing Suspend from my skin menu Does a clean power off as well.
    Choosing reboot works.
    No Suspend.
    I SSH into box and issued system command and received the above.
    I'm not sure if system is the command after logging in is what you meant. If so something is not right.


  • I SSH into box and issued system command and received the above.
    I'm not sure if system is the command after logging in is what you meant. If so something is not right.


    You have to exectute commands I posted in Code bracket if you want to make sure that internal memory is visible to LE kernel.

  • You have to exectute commands I posted in Code bracket if you want to make sure that internal memory is visible to LE kernel.


    LibreELEC (community) Version: 7.0.2.2LibreELEC:~ # mkdir -p /tmp/systemLibreELEC:~ # mount -o ro /dev/system /tmp/systemLibreELEC:~ # ls /tmp/systemapp                   framework             priv-appbin                   lib recovery-from-boot.pbuild.prop lost+found            ttschksum_list media                 usretc                   package_config        vendorfonts                 preinstall            xbinLibreELEC:~ #


    Pasted output above.
    Thanks again.

  • System partition readable, should be safe to flash on internal.


    Great work.
    Really fast box with this Version. Sandisk Extreme SD card 16gb used for this box.
    I cant tell it is running off the card speedwise. Quite amazing.

  • Hello! excellent job with openelec and this continues with libreelec!! I have a an MXQ M12 like the one in this photo and I've tested it with the LibreELEC-S805.HD18Q image and the LibreELEC-S805.MXQ image and I want to contribute with my feedback!


    with the HD18Q image everything works beside the LED.. it stays on after you shut it down, also the SPDIF passthrow dosen't work at all.


    On the other side the S805.MXQ image works perfectly!! wifi works led works and also SPDIF passthrow works!! the only thing that dosen't work is the remote control .. I use it when I have to turn it on and then I have to use the CEC remote from my LG TV.


    So I want to ask you if it is possible to add in the S805.MXQ firmware the remote control of the HD18Q, this way my device will work 100% !!! or if there is an easy way for me to upload the file of the HD18Q to the MXQ image! I tryed to change the file from the console but the system dosen't allow me..


    Also I want to add that the last working HD18Q firmware for my LED was the 6.0.1.1 also in that image the SPDIF passthrow works perfectly!! of course the image 6.0.1.1 had a problem with the network card and every time I was restarting the MAC address of the NIC was changing and my router DHCP was giving a new IP address.. anyway I really hope I've helped and I really hope for a cooked firmware that works for everyone in the future!!


    keep up the good job!!




    MXQ M12 metal edition with different openelec and libreelec every week Thanks to kszaq !!!

  • I just tested 7.0.2.2: everything works perfect and it does feel faster.
    And of course the PowerButton of my remote suddenly works after beeing ignored for 1.5years


    thanks kszaq, if everyone would be so helpfull the world would be a better place!

  • Nice job kszaq, as always ;) I've a curiosity, never tested or investigate about that: is it possible to use for example Samsung 's ir remote controller , or LG or others, after configuring it or it's mandatory a remote controller with nec protocol?:) Thanks :)


  • So I want to ask you if it is possible to add in the S805.MXQ firmware the remote control of the HD18Q, this way my device will work 100% !!! or if there is an easy way for me to upload the file of the HD18Q to the MXQ image!


    copy remote.conf that works into /storage/.config via SSH or, alternatively, the configfiles samba share. ;)

  • copy remote.conf that works into /storage/.config via SSH or, alternatively, the configfiles samba share.


    I'm using the SD version. It's posible to acess to the NAND and fetch the remote.conf from Android system directly with SSH without boot Android?


  • I've a curiosity, never tested or investigate about that: is it possible to use for example Samsung 's ir remote controller , or LG or others, after configuring it or it's mandatory a remote controller with nec protocol? Thanks


    NEC protocol is needed but most IR remote controls use it anyway. For hints, read these:
    OpenELEC Mediacenter - OpenELEC Forum - OpenELEC 5.0 for WeTek Play (1/2)
    Ir remote control - WeTek Community Forum


    I'm using the SD version. It's posible to acess to the NAND and fetch the remote.conf from Android system directly with SSH without boot Android?


    LibreELEC

  • HD18Q kodi freezes after few clicks. 7.0.2.2 NAND install. Same problem as 7.0.2.1. I managed to complete setup wizard after 3 reboots. Sometimes even network don't work. Log file attached.


  • HD18Q kodi freezes after few clicks. 7.0.2.2 NAND install. Same problem as 7.0.2.1. I managed to complete setup wizard after 3 reboots. Sometimes even network don't work. Log file attached.


    What is the last version that works for you? I've noticed you mentioned 7.0.1.4. Is 7.0.1.3 also not working?


    Thank you Kszaq, obviously if I'll map a new remote , I will always need to switch the box on with its remote controller, or I might change the uboot code? Thank you again


    It depends on your u-boot. I have one box that has configurable power button whereas others have this hardcoded.

  • What is the last version that works for you? I've noticed you mentioned 7.0.1.4. Is 7.0.1.3 also not working?


    It depends on your u-boot. I have one box that has configurable power button whereas others have this hardcoded.


    Mine is MXQ with red stripe on top:) thanks :)