Nightly images for A64, H3, H5, H6 and R40 boards

  • but it looks exactly the same .. absolutely identical.

    A radiator is installed on my board and you will not see anything....

  • This works almost ok, Plex is not working.

    But Wi-Fi is ok, and playback is ok.

    Thank you for the notification!

    I am very happy that there is at least some possibility ...

    First of all, please don't use formatting which would suggest screaming or needlessly seek attention. It's very distracting.

    I am very sorry for my inappropriate behavior. Unfortunately, I did not know the local conventions.

    Those issues you found out are exactly the difference between the boards you mentioned.

    That is quite obvious, and I have understood that before.

    There is OPi Lite 2 PR open, but it seems author lost interest (maybe requested fixes were a bit too hard...). Anyway, I don't have this board. If the PR author or someone else improve it, then I'll merge it. If not, well, bad luck.

    Never mind, so far I'm happy with the Archi's version.

    This more or less meets all of my current needs.

    And I believe that over time, even the OPi Lite 2 will become fully supported.

  • Desculpa, isso não é nada importante, mas existe alguma maneira de instalar na GPOI, LED's que mostrem a atividade do processador, leitura e escrita do cartão SD. Se alguem se interessar por isso, ficarei grato, pela resposta.

  • I have a small problem with an opi pc plus, I cannot get it to start with this version LibreELEC-H3.arm-9.80-nightly-20200402-d391e8c-orangepi-pc-plus.img.gz

    through the serial port it always remains stopped at the same point.

  • Removing "quiet" from extlinux.conf should show much more. Please do that. I tested current nightly image on OrangePi Plus 2E, which I have at hand and it works, so it has to be board specific

    Now if it has started, on television I have libreelec working, I have only changed the quiet option in the file that you have indicated. :)

  • Hi Vadim,

    I've been supporting Jernej with testing the Orange Pi 1+ since you started complaining about it not working and I've not been unable to reproduce your issue. I've decoded the dtb you sent and compared it with the dtb from the nightly and there are a load of things which look out of place. You just can't take the armbian dts and dump it into the libreELEC image, I can see that all the changes for audio are in the nightly dts but not in the one for armbian. I guess the code they use for the i2s drivers are different.

    Without your board to hand it's difficult to work out a solution, the main difference I see with the two dtb's is that armbian has thermal throttling added, but as you use a heat sink and I don't I can't say that this is an issue.

    Maybe you can recompile the armbian dtb with updated i2s values and recompile it.

    sound {

    compatible = "simple-audio-card";

    simple-audio-card,format = "i2s";

    simple-audio-card,name = "allwinner-hdmi";

    simple-audio-card,mclk-fs = < 0x100 >; <---change this to 0x80

    phandle = < 0x47 >; <--delete this line

    simple-audio-card,frame-inversion; <-- add this line.



  • Thanks, I think I’ve already tried it.

    I don’t remember what and how many times I tried to change ... comparing files .. but nothing works.

    where there is image output to HDMI, there is always no sound.

    here is another dtb. there is also an image with it, but there is no sound and the LAN does not work (error: cable is not connected)

  • Tell me, what screen resolution does LibreElec start up ??

    Orange PI One Plus works fine ONLY at 1024x768.

    Even in the Debian desktop distribution, when trying to change the resolution to any other than 1024x768, there is no picture, the sound is crackling.

    • Official Post

    It starts with the preferred resolution stored in EDID. If EDID can't be read, 1024x768 is used as a fallback and hdmi audio is disabled. So it seems that in reality, pineh64 image prevents EDID to be read correctly, which then in turn causes that fallback resolution is set (1024x768). On the other hand, when EDID is (supposedly) read correctly, something is misconfigured.

    Can you try on another TV or monitor?

    Anyway, if you enable ssh or serial terminal, I can give you few commands, which will hopefully show what is wrong.

  • I took the sun50i-h6-orangepi-one-plus.dtb file from the libreelec distribution and put it into the armbian distribution.

    there is no image at the time of initial loading.

    when the x-server and xfce start, a picture and good sound (via HDMI) appear

    screen resolution 1024x768

    it can be changed to 640x480 sound and picture are good.

    Other resolutions result in a blank screen and no sound (or crackle on the sound)

    EDID is present in the xorg log ... look please. Maybe something is wrong there?

    In my opinion, everything is within the expected range.