No internet connection

  • I started my system this evening and although I can connect to my addons etc, the box itself cant open Netflix, Youtube etc. There seems to be no internet connection but the internet in the house is fine.


    As I said, I can connect to the box and browse folders etc.

  • Who knows - probably a glitch somewhere.


    Give it half an hour, if issues still exist

    Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem.

    Full logs only. No modified logs.

    Do not post your logs directly into the forum, use pastebin.com and post the link.
  • Who knows - probably a glitch somewhere.


    Give it half an hour, if issues still exist

    Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem.

    Full logs only. No modified logs.

    Do not post your logs directly into the forum, use pastebin.com and post the link.

    Thank you. I enable debugging now and switched the machine off.

    Strange issue this.

  • When following the wiki I am unable to paste the link and view the short url because theres no internet connection.

  • knows - probably a glitch somewhere.


    Give it half an hour, if issues still exist

    Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem.

    Full logs only. No modified logs.

    Do not post your logs directly into the forum, use pastebin.com and post the link.

    I have this link but not sure of this is what you are looking for.

  • Is there really no one that can help me with this? It seems only the add-ons that does not have internet connection. Add-ons such as youtube, Netflix etc but sonar, transmission etc is working fine.


    This is really frustrating

  • Did you even try any addon like youtube or netflix? I don't see anything logged. And be sure debug is enabled.


    And can you run this two commands and post result?

    Code
    nslookup ix.io
    ping ix.io

    Gone...

  • Did you even try any addon like youtube or netflix? I don't see anything logged. And be sure debug is enabled.


    And can you run this two commands and post result?

    Code
    nslookup ix.io
    ping ix.io

    Yes I tried both Netflix and YouTube


    Here is the output


  • Sorry but there is no indication of any addon use in kodi log. Are you sure you select 'debug logging' in kodi?

    What happen when you open youtube or netflix addon? Does it open something?


    And can you run this command again? You wrote before it doesn't work?


    Code
    paste /storage/.kodi/temp/kodi.log


    And what about

    Code
    nslookup www.youtube.com
    curl https://www.youtube.com/ | head -c1000

    do you see with curl web page downloaded?

    Gone...

  • I did indeed enable debugging. When I try to open youtube I get an error at the top that states


    YOUTUBE ERROR

    CHECK THE LOG FOR MORE INFO


    I tried to upload a picture but the files are too big.


    In the paste below you will see what I mean when I say nothing happens when I run the first command.


    My htpc is also freezing now constantly, dont know if its the debugging but its not even 5 minutes then I need to switch the power off and on again and the time that this started was also because I had to restart the machine due to freezing.


  • What about

    Code
    cat /storage/.kodi/temp/kodi.log | curl -F 'f:1=<-' http://ix.io


    From what I see DNS resolution works fine (I suspected that's the problem).

    I suspect it is something with your setup like bad disk.

    Can you post result of command

    Code
    dmesg

    Then run command after every 30 seconds and check if you get some errors at the end.

    Or run this in one terminal

    Code
    watch -n 5 'dmesg | tail -n 200'

    Gone...