[S812] MIII Plus 2Gb\16Gb eMMC

  • Now I use the day time to help work on porting the kernel 4.x for S812 . Perhaps then I can return to the issue of support for WiFi in Minix. The main problem in this issue - I don't have that model so have to do everything at random and without verification.

    Thanks so much balbes150 I do hope you succeed in getting the right drivers for the AP6335 in the Minix working.

    Otherwise, I'm testing the latest MXIII_Plus right now on my Minix, it boots fine (I like the clean splash screen without all those status updates, nice!) and I've not encountered any freezes yet. Running in 1080p @60Hz all is real smooth.

  • If you used my GIT, you do not need to rename the script s805_autoscript. Leave it as it is. Activate the multi-boot and the system should normally be run by itself. Pay attention, the activation may be performed once and necessary SD card. Ie You need one time to record your image on the SD card. Use the update mode from Andoid or method of a toothpick. Once you upgrade bootloader, you can use to embed LE any USB flash drive or SD card.


    I am using your git, and have already activated multi boot previously, using your images, but none get past the filesystem error message without renaming the s805 script for use instead of aml_autoscript. I can try again next time I reboot the thing, but the last time I had it working, USB wouldn't work either.


    Using the renamed s805 I'm at least able to boot, though in a roundabout way as I have to manually mount system. As I said I'll try multiboot once more and see how it goes.

  • Nope, doesn't work on the bcm4335 model. Multiboot works in that LE tries to start, but mmcblk0p1 isn't being mounted as /flash (something else is) and so the SYSTEM image isn't available automatically.

    • Official Post

    Nope, doesn't work on the bcm4335 model. Multiboot works in that LE tries to start, but mmcblk0p1 isn't being mounted as /flash (something else is) and so the SYSTEM image isn't available automatically.

    1. What is your model of TV box ?

    2. Show me the output of fw_printenv from a running LE system (console of SSH).

    3. What version of Android was used (from which firmware version 4.4 or 5.1 you have u-boot) ?

  • 1. The model on the board itself is M8 v8.9 - the firmware it uses, stock, is cyx_m8s_v8.6_bcm4335_8g2g_kodi_addons_160125_USB - there was a newer release but it wouldn't flash for me...odd that the firmware it uses is 8.6, while the board is labeled 8 .9. My dtb file is somewhere earlier in the thread, and as a patch in my fork of your LE repo.


    2. idUI


    3. I guess it would have to be 4.4, no versions beyond this have been functional.

    • Official Post

    Questions to the owners of Minix H8Plus (s812)


    1. Do I understand correctly that when running on Minix version (20170602) MXIII_Plus wired network works, sound and video works, WiFi doesn't work. What with BT , working or not, the adapter is enabled in the settings ?

    2. How the system behaves from the image LAN1000 on Minix that works in this manner (wired LAN, BT, WiFi) ?


    Similar questions for owners of the model Minix H8 (s802).

  • balbes150

    You are correct when running MXIII_plus on Minix X8H- plus wired network works fine

    As does sound and video .BT does not work Wifi does not work

    Same with LAN 1000 no wifi no BT not working

  • The test version for H8X_plus.


    Yandex.Disk


    Have you tried the option LAN100 ?

    balbes150

    I just tried your test version for Minix x8h- plus boots ok

    In LibreElec network settings there's only wired network option

    There is no option to turn on wireless network whatsoever

    Thanks for your attempts to get this to work

  • balbes150


    Regarding the LAN1000 version:

    - The LAN1000 build of April 18 works fine, all works EXCEPT Wi-Fi and Bluetooth

    - The LAN1000 build of May 13 doesn't work, after splash screen the Kodi interface never comes up


    Regarding the LAN100 version:

    - The LAN doesn't work on my Minix X8-H Plus

    - However this one will probably work on the Minix X8 and X8-H as those have 100 mbit LAN


    Regarding the LibreELEC-S812.MXIII_Plus.arm-17.3 version:

    - Works fine, all works EXCEPT Wi-Fi and Bluetooth


    For both the LAN1000 and the MXIII Plus builds:

    - Wi-Fi is present in the LibreElec options, you can turn it off and back on. Turning it on even makes you wait. However, no Wi-Fi networks appear in the Connections list, only wired.

    - Bluetooth just states that no bluetooth device is found.


    Personally, I don't care about Bluetooth, all that matters is getting Wi-Fi to work.


    I'll try your Minix test build tomorrow. Thanks so much for your efforts!

  • Comparing the Minix models:


    Minix X8:

    - S802, 100mbit LAN, Wi-Fi 802.11b,g,n


    Minix X8-H:

    - S802-H, 100mbit LAN, Wi-Fi 802.11b,g,n


    Minix X8-H Plus:

    - S812-H, 1000mbit LAN, Wi-Fi 802.11ac (b,g,n)

  • Thx for the update.

    Works great for me on MX3 Plus, beside 4K is still not functional.

    Maybe somebody can give me a hint.