[S812] MIII Plus 2Gb\16Gb eMMC

  • For operation modes, a reboot is necessary to remove from the media (after activation of the multi-download) the file aml_autoscript. When the system reboots and tries to re-use aml_autoscript



  • Makaa, how did you succeed to activate multiboot, for god's sake? I have M8S+ which is mostly the same box but with 1000Mb network card and no chance to succeed with any of the images, rufus, win32 disk imager, I even tried with 2 different SD cards.
    How do you know that you activated multiboot? Actually, it doesn't matter... I have kerber's Libreelec which is working fine, except you have to replug it every time you shut down box, but the rest is fine.


    I give up, but would like to know what you've used to produce bootable sd card...

  • Hi Dankec,
    Used rufus 2.11p.exe & Used Kingston 16gb SD card
    Select your card drive & select downloaded .img.xz file & press start.


    Let it write. Once done...


    Put it in M8S sdcard slot -> hold reset button with toothpick while inserting power plug -> wait only 5 - 8 seconds only (or as soon as you see M8S logo release it) -> release tooth pick - wait 10 seconds & remove power & SD card.


    Make again new USB key -> delet aml_autoscript file -> insert into any one USB -> insert power plug -> logo S812 or M8S comes -> wait...wait...wait.... LibreELEC will show up within 30 to 40 seconds ->first time takes time -> first time it will setup system & will reboot by itself -> now it will boot directly into LibreELEC after M8S logo.


    Makaai...

    Edited once, last by MakaaiD ().


  • Thanks, Makaai. I did try once again with the same image maker and the same firmware as you, but I'm using Sandisk SD card 16gb.
    Same result, same (logo - black screen-logo) problem. I give up and will wait for Kerber's future solution, or will return to openelec 6.95 which is working just fine.


    Thanks all and bye!

    Edited once, last by dankec ().

  • Hello I bought ((Akaso M8s - S812 - 2G/8G with wifi chip RTL8723BS )) and ihave TWRP and root
    my problem Bluetooth does not work as well as Wi-Fi Direct does not work, so i can not cast any think to m8s
    >>>>>>>
    pleas Can you help me find the firmware: or Backup For the same device with wifi chip RTL8723BS.
    Sorry for my weak English.
          

  • Hello I bought ((Akaso M8s - S812 - 2G/8G with wifi chip RTL8723BS )) and ihave TWRP and root
    my problem Bluetooth does not work as well as Wi-Fi Direct does not work, so i can not cast any think to m8s
    >>>>>>>
    pleas Can you help me find the firmware: or Backup For the same device with wifi chip RTL8723BS.
    Sorry for my weak English.

    Edited once, last by alaliali ().


  • balbes150: are there Krypton experimental builds around, or can you build one?
    Thanks! :)



    The Assembly version with a krypton planned, but I don't have the time to do it.
    [hr]



    Maybe need firmware is on the site Amlogic. You were looking for ?

    Edited once, last by balbes150 ().

  • OK, now is 100% clear. I made SD cart with win disk imager, but no luck... It just shows M8S+ logo then go back to black screen then back to logo, to screen and so on... I've been holding reset all that time. So I even cannot go to libreelec screen. I will try with 20160906 now.


    EDIT: WHen I replace script s805_autoscript with old one from your download then it freezes on M8S+ logo after releasing reset button.


    EDIT 2: No luck with 20160906 also. It freezes at the very beginning on M8S+ logo.


    Thanks for the all the work being done on this release, however alarmingly I seem to be unsure on step 1 'download img.xz' - where do i download this for the latest stable version for Beelink MiniMXiii 1000m LAN?

    Edited once, last by valheru ().

  • All my builds are here to S812. I have only have one model Tronsmart MIII Plus ver 2.2. So I can guarantee the operation only for this model. For all other models - that-be to get a working version, I need feedback from testing. If you are willing to be "Guinea pigs" to test, I'm willing to try to collect the right version. But I warn you, it's not a quick process and requires patience and time.


    Yandex.Disk

  • I gathered BETA image using the source kernel KSZAQ for the 3.10. Included in the dtb data for multiple devices S812 and S802. Request to the owners of different models S812 and S802 , who have the opportunity to try to run it with the external media. I am interested in the fundamental performance of multivariant dtb data simultaneously for S812 and S802.



    dF7ASRFGygDMj


  • All my builds are here to S812. I have only have one model Tronsmart MIII Plus ver 2.2. So I can guarantee the operation only for this model. For all other models - that-be to get a working version, I need feedback from testing. If you are willing to be "Guinea pigs" to test, I'm willing to try to collect the right version. But I warn you, it's not a quick process and requires patience and time.


    Yandex.Disk


    Hi balbes150
    My box is a new box. I never use it basically when it came I get allot of errors. I try to update firmware I get errors. I try to make a factory reset and the box frizzed after an hour and half I turn off the box. Since then never worked. It is completely new. I bought the box around 1 month ago.


    Please can you explain:


    1) How to use the LibreELEC USB-SD Creator. Because I try to do that but the software asks for a file with an extension *.gz not *.xz and don’t accept xz.


    2) Basically I would like to try to use the LibreELEC with your MXIII_C Version Can I do that?


    3) Inside the MXIII_C folder It has a file kernel.img and than a folder with a file inside --> LibreELEC-S812.MXIII_C.arm-7.0.2.5_20160915.img.xz
    How to install this?


    My BOX is:
    MXIII-C V1.1 S812/2G/16G/AP6330 (PCB 1.5mm) with MXIII-C_V1.2_20160419.
    Date: 2016.07.14


    The Nand Is:
    Foresee NCEMBSF9-16GB
    01L1605118552
    1620


    The software was always crashing and now I can only see the red light.


    I try to use the following firmware:
    MXIII-C_202L1 for USB Burning Tool


    I try this firmware with the following USB burning tools
    AMLOGIC_TOOL_setup_v2.0.5.15_build9
    USB_Burning_Tool_v2.0.6.2_build2
    USB_Burning_Tool_v2.0.7_x86


    at 3%
    When I try these USB burning tools I always get an error message like this: [0x10205004]Romcode/Lead UBOOT/Check decompress/Error result


    MXIII-C_202L1 SD for sd card
    I try this firmware on SD card but nothing happen. I used the toothpick to hold down the button inside the AV port,

    Edited once, last by Redcat22 ().

  • 1. To capture the image , it is necessary to unpack such program 7zip. If You do not get to unzip, email me, I will upload to the site is not Packed version of the image for recording.
    2. Yes, You can try two options - catalog MIII_C or the latest version from the directory MIII_Plus (in latest version added the dtb data from many models in a single file).
    3. The file kernel.img need for manual replacement in the same images ( they are not written to the external media). You need to use the images (pokerspace) with the xz extension.
    4. If You fail to start LE because of problems with internal memory, you can try to force it to operate Your TV box with external media without the use of internal memory.

  • OK I can use the 7zip to unpack the *.xg image and than I get an *img. Done.


    Can you explain me this better please:
    3) manual replacement of kernel.img what this means? After save the image to the SD card replace in the SD the image?


    4) If You fail to start LE because of problems with internal memory, you can try to force it to operate Your TV box with external media without the use of internal memory.


    This is what happens to me. How can I force to operate without the use of internal memory?

  • 3. You file kernel.img is not needed. This file is intended for other purposes.


    4. You have two options. If u-boot in internal memory intact, you can activate a universal-boot and run different systems from external media without changing the pitch. If u-boot does not work, then you can block an appeal to the internal memory and use the boot loader from external SD card to make small changes to the scripts and run the system entirely from external media.


    Have you tried to activate the multi-boot ?

    Edited once, last by balbes150 ().


  • Same error here and resolved by connecting the box to an USB2.0 port.