Odroid C2 poweron from CEC lost after upgrade to LE 9.

  • Hi everyone!


    Since my 8.2.5 LE was working stable and perfect, I got bored and decided to upgrade to 9.... ;)

    Before upgrade, when I turn off my tv, the box shuts down, but CEC circuit seems to keep working - after powering back up tv, I see "Odroid C2" device under SmartLink menu and when I choose it, the boards boots up. When I tested the same on Khadas VIM, I missed this feature and noone was able to explain, where to start digging for solution. I just sold Khadas and moved on. Now I am frustrated, because after powering on tv, no CEC devices are visible and only way to start my C2 is to go to tv and power cycle, but I am too lazy to do that.

    Has anyone had the same problem and found a solution?

    There was nothing in peripherials, that would change this behaviour, except for changing "Action on TV off" to "Suspend" which actually prevented any reaction to powering off my tv. But that blinking blue led is just asking for a rework gun - i hate flashing blue lights... :cursing:

    Still, I see a lot of improvements on LE 9 and would not want to move back to 8.2 if i could do anything about that shutdown/powerup feature...

    And what I would give for a tv with AML S905 and Libreelec on board...

  • Just found out that the problem is a snafu in u-boot in LE9

    Version of CEC firmware in LE9 is 6 and that is buggy. In LE8.2.5 it was version 5.

    Probably, a solution is to go back to previous version of u-boot. Did not have time to experiment today.

    Some of it is explained here - odroid-c2:application_note:ir_wake_up [ODROID Wiki]

    For the same reason, CEC wakeup did not work for me on Khadas VIM.

    Returned to 8.2.5 - feel sorry for not taking full image of emmc.

  • I have the same problem as well on libreelec 9.0.1 on an Odroid C2.

    Is there a fix for this yet? (without downgrading?)

  • Sadly, noone from AML-oriented guys left any remarks here...

    Tested Khadas VIM 1 - same story - have to get up my lazy self to go to box to switch it on.

    Have heard that Khadas implementation is different and solution might not exist.

    I will try to brutally flash different u-boot and see where it takes me...

  • Sadly, being a router-guy I cannot seem to figure out uboot stuff that easy and not a lot of time on my hands too.

    Still, willing to try just about anything I can to revive a perfectly working media distro on both C2 and VIM boards.

    Anyone that has a hint, plase drop a line so that we can experiment together on this.

  • You're welcome to test the AMLGX mainline kernel test images on a C2 board.. balbes150 is creating them until official nightly releases start. I can't speak for how CEC works as I never test it or use it, but if there's a defect there people will be actively interested in understanding the problem and finding solutions (maybe not immediately, but it will go into the general mainline work-pile).

  • Before upgrade, when I turn off my tv, the box shuts down, but CEC circuit seems to keep working - after powering back up tv, I see "Odroid C2" device under SmartLink menu and when I choose it, the boards boots up.

    Having Odroid C2 (on LE9) I'd be grateful if you could delve some info on how to setup CEC to do the same thing. I'm leaving C2 always on, your approach seems like a much better solution!


    Furthermore, I do see that the blue LED has started blinking again, after upgrading today from 8 to 9. Is this a known issue?


    EDIT: I see that it is configurable, which is great. I've set it to blink on sd card access, don't know if it could do that thing before.

    Edited once, last by cosmos ().