safe mode, and now?

  • libreelec is in safe mode, and i have no idea what to do.

    can you please help me.

  • I had a safe mode issue, too, shortly with LE 9.1.002. I think it was triggered by a settings change I made.

    I have been changed "Settings -> Services -> General -> Device name". My advice is to keep this setting untouched at "Kodi".

  • I too am having the same issue as above. My log file is similar to OPs.

    I have tried renaming the profiles.xml file in both KODI/KODI.FAILED directory.

    Pasting the contents of a working profiles.xml (from varies forums) into each profiles.xml in each directory systematically.

    Deleting guisettings.xml.

    Deleting KODI. folder, rebooting.

    Deleting KODI. folder, renaming KODI.FAILED to KODI.,rebooting.

    I have no files in /storage/.kodi/temp/ to delete.

    And I have no idea how to fix it. Any suggestions would be greatly appreciated at this point

    Rasperry pi 2

    Libreelec 9.0.2

    KODI Leia


  • I too am having the same issue as above. My log file is similar to OPs.

    Since downgrading to LE 9.0.2 I have no safe mode issues on my RPi anymore.

    It looks like your microSD card is bad:

    Core was generated by `/usr/lib/kodi/kodi.bin --standalone -fs'.
    Program terminated with signal SIGSEGV, Segmentation fault.

    So check the card for bad blocks, and eventually repair (GParted tool, only for advanced geeks) or replace it.

  • Try creating profile.xml in ./kodi/userdata


    Display Spoiler








    <name>Master user</name>

    <directory pathversion="1">special://masterprofile/</directory>

    <thumbnail pathversion="1"></thumbnail>


















    Save and reboot.

  • Thanks, Iridium !

    I tested the profile.xml you share again and it worked after reboot! :) (I created in .kodi.FAILED folder too). I probably did something wrong in the first time.

    My logs say something to I know what the cause of this?

  • @edjalmo Sorry no idea. Never experienced the "Safe Mode" nor did I know about the Wiki entry before this.

    Error was:

    2019-11-06 07:31:07.251 T:1936753312   ERROR: CProfileManager: error loading special://masterprofile/profiles.xml, Line 0
                                                Failed to open file
    2019-11-06 07:31:07.251 T:1936753312  NOTICE: special://profile/ is mapped to: special://masterprofile/
    2019-11-06 07:31:07.251 T:1936753312   FATAL: unable to load profile

    Do you run with profiles?

  • My suggestion is the same: Check your microSD card.

    Using the GParted tool, like you suggested above?

    Edit: this is a bootable image, don't sound like it's a easy thing to use :/

    Can I copy my entire sd card to another new, and if this problem is with this sd card they will not happen again, right? If yes, how can I do this (since exist hidden partitions/folders)?

    This SD card had total uptime in LibreELEC of 200 days and had no problem until today. The only thing that happened before safe mode was in Sonarr, this monday his the db had corrupted (but I restored one backup and back to normal).