Slow SMB access with LibreELEC 9

  • Upgraded to LE 9.0.0, all of my media is on Synology that I access via SMB.


    Synology is configured as:

    Minimum SMB Protocol: SMB1

    Maximum SMB Protocol: SMB3


    On LE:

    Minimum SMB Protocol: SMB1

    Maximum SMB Protocol: SMB3


    I am using a wired connection and I am getting lots of buffering of files that played correctly on LE 8.


    I tried setting Maximum Protocol to SMB3 on LE, with the same results. /shrug


    BTW I'm running LE on a ChromeBox

    Edited once, last by labzilla ().

  • SMB seems to have its hiccups in Leia 18.

    Why not try NFS instead, Synology should be good at that as well.

  • Yes NFS is an option, but I wanted to know why SMB wasn't working :)


    I've discovered on kodi.tv that there is a SMB performance bug in the 4.19 kernel. You need to /flash/extlinux.conf and add pci=nomsi


    the /flash filesystem is read-only so you'll need to remount it: mount -o remount,rw /flash


    Code
    1. DEFAULT linux
    2. PROMPT 0
    3. LABEL linux
    4. KERNEL /KERNEL
    5. APPEND boot=LABEL=System disk=LABEL=Storage quiet pci=nomsi


    Hope this helps anyone havin SMB performance issues, it worked for me.

  • Instead of adding pci=nomsi (which did not fix the samba issue and disabled all usb ports on my haswell box!)

    Try adding pcie_aspm.policy=performance instead.

    Thanks go to Matt Devo on the Kodi forum for this tip..

  • I tried that as well.

    At first it seemed better, but after a while it also began to stop and start during playback.

  • The problem is not only with samba, it's because of the shitty realtek network drivers in kernel 4.19 upwards.

    202945 – Realtek rt8169/rt81xx performance issue in kernel 4.19


    I've also tried the workarounds mentioned there, some seem to improve the situation, but after all it's still there. If you have a realtek network card and only want to watch movies from a samba server, try to modify the video cache

    HOW-TO:Modify the video cache - Official Kodi Wiki


    Kodi has an excellent cache mechanism and with decent settings you can hide the problem (I've nearly no stalls while watching movies from my library). But that doesn't help for playback methods, where Kodi hasn't implemented caching (LiveTV, Netflix, Amazon), they are still nearly unwatchable

  • I reached a maximum bitrate of around 20Mb/s before it started to eat away the buffer while using smb mount in libreelec. But when mounting the smb share directly in linux the buffer remains att maximum even with bitrates over 40Mb/s.


    take a look at /storage/.config/system.d/cifs.mount.sample. or just google it.