Retroplayer - ScummVm

  • I updated to 9 today and wanted to try the ScummVm Addon.
    First i couldn't find it because for some reason it is under "Support-Addons".
    But anyway, i installed it but now i cannot find a way to start it.
    When i select a .exe file i don't have ScummVm in the selection.

    Do i need some other addon to use ScummVm?

    Edited once, last by movedoa ().

  • I am experiencing the same issue, after I install the scummvm addon there is no way to execute or add games to it. Any idea?

  • hello, i have the same issue...

    even when i add *.scummvm files with their correct game id assuggested, those files do not appear in the "file browser" at all.

    i am using LibreELEC 9.0.0 on a RPi3B.

  • Hi CvH,

    Thanks for checking !

    Actually we opened first a similar post on the kodi forum, but based on the answers we received there seems some people is experiencing a different, more correct, behaviour in kodi, so we wanted to focus on the discussion here, please take a look:

    How to use ScummVm?

  • Ssome news about this?

    I saw this thread in Kodi Forums, but there seems to be no conclusion!

    today I made a fresh installation on a rp3+, but still the installation of scummvm seems a little buggy.

    So, when it's installed, it crashes...

    And i don' know event where to put these .scummvm files

    Thanks for advise,


  • Hi vpeter,

    thanks for that, but I'm not authorize to open this part of the forum! ;(

    Maybe you can repost the solution here?



  • Thanks vpeter,

    this works on my rp3; I've to do some testings with this.

    But, can you do me a favour? This RP3 is just for testings, my main device is an Odroid C, so could you maybe do a rebuild for the arch64 platform too?



  • works like a charm...

    Thank you very much!!!

    Maybe you can update the addon repository to deliver these new build!



  • vpeter , thank you for recompiling and giving the zip file for RPi2...

    i just tried to reinstall the add-on via LibreELEC repository, but without success (ScummVM still not working).

    1. tried to update the add-on - not able to see if the new code was loaded, because of the version number is in both versions.

    2. tried to deinstall and reinstall the add-on from LibreELEC repository.

    in both cases the add-on was installed successfully, but ScummVM didn't worked.

    but installing the zip file is working...!

    why not changing the version number from to or at least or so, to trigger an automatic update of the add-on in LibreELEC? and with a new version number it is possible to easily distinguish the new version...

  • From what I see the version is already in LibreELEC repo.

    But what is strange that it has same bug:

    08:06:47.563 T:139834346896704   ERROR: AddOnLog: ScummVM: Unable to load: /storage/.kodi/addons/game.libretro.scummvm/ undefined symbol: _ZN3GUI13OptionsDialog5cleanEv

    Also size of the library is much different: mine is >30MB, from LE repo ~2MB.

    Will investigate later what is going on. Maybe it is be LE addon build environment .


  • maybe i was too early with trying the LibreELEC repro... today i see that there is a new version

    and it is also comming with automatic add-on update.

    but as you mentioned... the version seems to have the same issue as in the previous version from LE repro.

    EDIT: by using the working add-on from the zip file, i have two of my games those cause Kodi (LibreELEC 9.0.1) to crash.

    Discworld 1 (german) and Monkey Island 3 (german).

    Discworld 2 (german) and Monkey Island 1 & 2 (german) are working.

    diskworld 1 is crashing immediately when starting the game,

    monkey island 3 is crashing after the menu / logo (just after the monkeys fall silent).

    in both cases there is no log from that happening after kodi started.

  • I only looked why addon doesn't even load. Didn't check why it crashes with games because I don't use games at all and doesn't have any controller.