SMB not working

  • First timer here so hope I convey and did this all properly.

    Version tested:

    device tree: gxm_q200_2g (2gb + 1Mbit ethernet)

    Device: GooBangDoo Abox A3 w/S912, 2gb+16gb flash

    When trying to added an SMB share I get an "invalid argument" error. It sees other connected computers fine but that last step of browsing for shares is when the error pops up. I searched and read quite bit about these issues so I tried a number of things. I messed with every combo of Min/Max SMB setting I could and no change. I even tried the 8.2.4 Tweaked version for the heck of it. Oddly I can access this device from another computer on the network and move files to/from it just fine. If I remove the SD card and boot from the internal flash flash drive to Android 6.01/Kodi 17.6 SMB has and still works fine. I'd really like to get this working as the memory footprint on savings is huge! I do not have, nor will, run any Android apps so it's just Kodi and I felt ridding the Android massive OS would be good. And even running Kodi it's one add on, Aeon Nox: Silvo skin, IPTV paid sub, and my library rips of movies & music...pretty clean.

    Appreciate any help resolving this. Was going to hunt down a Leia install but my head is already spinning and thought I'd start here.

  • You're about the 264,983th Kodi user complaining that Samba is no longer working... ;)

    It's 99% because of the change in SMB version. So whatever is still working now, is probably still using the old insecure SMBv1 protocol.

    Until last year, lots of network devices used SMBv1. After the whole WannaCry disaster, Microsoft finally defaulted SMBv2 as the successor of SMBv1 in the 1803 update, with among the changes:

    - Windows users require a password for SMB access

    - SMB network browsing is no longer supported.

    So, once your Windows "server" has SMBv2 enabled, you can use the "Add a network location.." option in Kodi, enter full credentials, and "things should work" (tm).

    There are plenty of other threads on this and the Kodi forum on this topic, so feel free to do some extra reading.

  • The SMB client in LE 8.2 based releases defaults to SMB2 and SMB2 does not support browsing so this will always fail. If your server supports SMB2+ you can configure it manually - use an authenticated connection (use username/password). If it does not support SMB2 your only option is to force Kodi to use SMB1 .. set the SMB client to min and max SMB1. If it's really crap and ancient, you might need to set the legacy security option.

  • Sorry guys I knew this was posted multiple times but the fix comments I had tried and figured this was my last resort to ask. I'll tinker with those SMB settings once more as I swear I exhausted those already. Curious...aren't the SMB settings in two locations? Under Services and then again under the LibreELEC settings? Doing it from memory at the moment. Maybe that's where I went wrong in my experiments to cure the problem.

  • Thinking on this further I suspect, as I mentioned above, with the settings being in two places one is incoming and the other outgoing? I think that's my problem and also explains why incoming SMB connections worked fine and I could move files. I didn't realize SMB could be configured separately for incoming and outgoing. I think this is it and sadly can't test till later...maybe someone can confirm this?

  • I confess that I was configuring the server side and not the client side and did not realize there was separate settings for each. Upon setting that to SMBv1 for Min/Max all was cured and I could now browse the shares just fine. Sadly I was mounted to a test Windows 7 Pro machine and thought I had it down pat what was needed to be done and set off to configure the machine that houses my 16TB's of movies, music, and pics, Now I can not replicate what the hell I did to get around this problem with all the same settings. Then I read how browsing shares is no longer possible yet I'm doing it on one machine but the same settings will not work on a near identical configured Windows 7 Pro, can't even get in at all but can see it. If I use an IP address and then "/Movies" the SOB works but is slow. I did manage to get a login screen but the correct password would not work, and I reset the password to test that and still no go. This has turned into an exhausting mess for days that has left me wondering, "WTF am I wasting all this time for". Case in point. I test drove an OpenELEC nightlight build..worked like a champ or so I thought. Lost remote support and next thing ya know I'm using some program called "Putty" to SHS the remote config file over. Finally got that to work but I was left saying to myself, "Wow I'm back in the 70's dealing with DOS". Have we gone back in time here? Why is there no easy way to do an add on for a simple remote anymore? 17.6 worked out of the box but 18 needs some messed up method to get a remote to work makes no sense to me. I'm about spent on this thing and think I'll just live with my Android OS hogging to much memory..least the SOB runs flawlessly without all this headache. Between SMB changes and remote BS all I can say is "F THIS"....was like a bad time warp gone wrong.

  • this made a mess beyond belief. Now none off my computer wired in the home can access one another. Can be seen but a Windows 7 to Windows 7 connection can't be connected. I get a "Windows can not access" error message with all 3 machine with no explanation but why the heck is it seen if it can't connect? I should have practiced the old belief, "If it ain't broke don't fix it" nothing works. Wife so gonna kick my ass in the morning, and with good reason. This crap is just that..crap

  • LE settings addon = embedded Samba *server*

    Kodi settings = embedded SMB *client*

    The current complexity is caused by Microsoft not ourselves, but it's not particularly hard to configure things as long as you stick to a couple of basic principles. The main one is that all connections must be authenticated with a username/password. The second is YOU CANNOT BROWSE from Kodi (on LE) to a Windows server so sources must be configured manually. I find it easier to manually edit /storage/.kodi/userdata/sources.xml over an SSH connection than fiddle with an on-screen keyboard in the Kodi GUI. The format is simple:

                <path pathversion="1">smb://username:[email protected]/MEDIA/</path>

    Edit the user/pass and paths to suit - the format of the file is simple.

    If you force Kodi to use insecure SMB1 the browse feature works. If Kodi uses secure defaults (SMB2/3) there is no browsing. OpenELEC "works" because it's old and outdated - the latest version is from May 2017 which pre-dates the SMB2/3 features being added to Kodi (after the WannaCry problems) so it's using SMB1.

  • I hope he is just mixing up the *ELEC names. I don't think there ever was an OpenELEC for a S912 Android box. :)

    Didn't mix it up at all. The first post was just about LibreELEC and I had later stated I was thinking of giving Kodi 18 a try. Then a few posts down I did just that but could only find it in an OpenELEC and chose a nightly. Gets confusing I know trust me.

  • Hate to say this but some of what you say I found to be untrue. I'm browsing SMB shares on a Windows 7 machine but I'm using OpenELEC at the moment...that the difference? I can even rowse from that Windows 7 machine to Kodi. I'm also having fits with network access on my pc's that I've never had before. Here's one for ya. One of my Windows 7 machines is wireless, soon to rid that I think after what I'm about to explain. With a wireless connection if I turn on password protection nothing..I mean nothing..will get in and I even created new accounts and turned on guest account to figure this out. It's as if password authentication is somehow broken and returns an error. This caused me to stumble on a little bug I don't like. If you check that box to remember credentials it will even if you entered a wrong password and then any subsequent click on a network share throws a permissions error...not even a incorrect password thingy to fix it. I had to go in and delete the saved credential and stop myself from checking that box till this was So I hard wired it with a 75ft cable out of frustration...still won't access it but turn off password protection and both Kodi 18 and my other Windows 7 browsed shares no problem. That make any sense whatsoever? Ohh forgot one thing when it was connected wirelessly...if I turn back on Homegroup and use that password on my other machine it was fine...all messed up when all leave the Homegroup and normally I can setup a network without using Homegroup at all. Thought SMB in Kodi needs password authentication? Didn't here. Using password authentication on one machine nothing would get in.

  • I'm just one of the two people who implemented SMB2/3 support in Kodi. I think i'm under-qualified to help further.

  • Wasn't trying to offend. Just tried to be factual that I can browse SMB shares and one machine worked with password authentication turned off. That machine seems to be an odd duck as it behaved backwards of a near identical windows 7 machine in other room...puzzled the hell out of me. I'm curious when I rid this 75ft cable it all goes to crap again because nothing I could do when it was wireless would get in.

  • but I'm using OpenELEC at the moment...that the difference?

    As far as I know, OpenELEC only supported SMBv1. Unfortunately, the OpenELEC maintainer has been M-I-A for almost 2 years now. Microsoft has done plenty of changes to the whole samba sharing via its Windows updates, and it's too bad the user-interface as far as networking goes for the average Windows user, hasn't improved in terms of user-friendliness or clearness.

    I've been using Ubuntu Linux as my daily driver for almost 10 years now, as well as the NFS protocol for my Kodi file needs. So, no I don't have all the Windows answers.

  • If you degrade your Win boxes back to SMB1 and use a wildly out of date OE image .. sure it works. If that's all you want .. fine. If you want to use a secure Win setup your boxes need to disable SMB1 (and with that .. browsing them is dead) and use SMB2/3. At this point the old OE image will fail to work because it has no support for SMB2/3. You'll need an LE image which supports SMB2/3 just fine. Get the current Beta.Create a Kodi user/pass on Windows and assign read rights for that user to the shares (and forget that guest access ever existed). If your Win boxes allow SMB2/3 all you now need to do is manually configure the sources in Kodi to use the same kodi user/pass credential.

    Or you can keep wildly changing stuff and hoping it works. Or stick to OE (but then future posts should be in the OE forum not here).

  • I only enabled that guest account because this one computer is giving me fits with user/pass. If I enable password authentication I get this error when I click on the share. Remove requiring passwords and it goes away. I've been reading and reading up on this to no end, without finding the cure.

  • And maybe I missed a Kodi 18 LE for AM S912 but I couldn't find one...S905 I did. That's why I headed over to OL to have a look and it was right on the front page so I said what the heck.