SMB only working with guest access

  • Hi,


    I have been reading a lot of issues with users who have guest access enabled on their SMB, which is no longer working. But I have it the opposite way around:


    - central storage on NAS, accessible via SMB with username/password protection

    - central MySQL DB with the libraries

    - Windows with KoDi, which updates the libraries (all working fine)

    - RasPi with LibreElec, accessing the same MySQL server. This one does not updates on the libraries.


    When I enable guest access on the SMB of my NAS, the LibreElec works just fine, but off course I don't want that. As soon as I disable the guest access, LibreElec can no longer read the files (unix_err:'d' error : 'Permission denied').


    LibreElec has never asked for any password for the SMB. So I manually tried to add the video sources, entering the SMB user/pwd there. I can browse the sources with the file explorer perfectly fine, but still no video can be started from the libraries.


    I have then copied the sources.xml from the Windows PC. There is a passwords.xml file with the password for SMB access to the NAS. Still no luck.


    Though my NAS supports SMBv3, I have tried setting the SMB service to force using v1 (and after v2 and after v3), finally setting all to "none" again since this was not working.


    Does anybody have any idea what could be wrong here? Since off course, I don't want to allow guest access to my NASses SMB...


    Thx!

  • There's nothing exotic about your setup so as long as you're using valid credentials it should just work. No need to force to SMB1 or use legacy security as long as you're using LE 8.2 or newer as SMB2/3 are supported.


    NB: If sources.xml contains Windows smb:\\server\path references I'm not sure how those are interpreted on Linux where smb://server/path is used (backslash vs. forwardslash).