SMB shares not working - LibreELEC 8.95.001 on Raspberry PI 2

  • I just upgraded to Official version 8.95.001 on my Raspberry PI 2 and now I lost connectivity to my SMB shares on a Asus RT-AC1900P


    I think it has to do with SMB protocols SMBv1, SMBv2, etc, but I can't make it work. I can connect to those shares from many other devices.

    Yes, they are password protected.


    I do not have SMB Service enable, because I do not share any of the local storage.

    But I do connect to the network share on the Asus which uses Samba to share a USB drive with all my media.


    So, I tried SMBv1 as Minimum protocol version and SMBv2 as Maximum protocol version under SMB client but still not working.


    I have read some possible solutions but I wanted to make sure and check in this forum. I will appreciate your help ! :)


    Thank you !

  • Kodi uses the smbclient from Samba which defaults to SMB2, so if you enable min SMB1 and max SMB2 it will use SMB2 and you will not be able to access your SMB1 share. To force SMB1 you need to set min/max to SMB1. You may also need to enable the legacy security option; depending on how ancient the SMB code is in the router.

  • Hello Chewitt,


    I did try setting the service to SMBv1 (min and max) with no luck. I have been trying with past builds, finding that since Build 8.2.5 all fail to connect to my smb share on my router. Previous versions are ok.

    As you mention, I may need to enable legacy security option but I see that as 'grayed out', basically can't select it.

    Is there a way to have that enabled or even modify something on the smb.conf for the service to make it work on newer builds ? (Leia)


    Thanks !

  • I have the same problem.

    But I can not find this legacy option. Can someone post a screenshot where to find it?

    Using a USB-disk connected to my fritzbox and try to reach it via smb from LibreELEC on my raspi 3

  • The legacy security option is visible when SMB1 is set for min/max. You need to configure this in Kodi SMB settings not the LE Samba settings (which are for Samba server, not client).

  • Settings > Service > SMB client .. screenshot below from the current 9.0 beta. You need to have Advanced or Export settings mode to see the SMB client options:


  • Ok, after enabling both mix, max settings to SMBv1 the option for Legacy security become available and I enabled it.


    Now all is working as before ! Thank you much Chewitt !