Support for Intel NUC 8i7BEH ?

  • One last question JB.. have you tried a movie with HDR? I know the HDR on Intel Drivers is still a work in progress... but just checking if it is good now or if it is getting better.

  • I have a 8th gen i3 and no problems with LibreElec Leia viewing 4K UHD HEVC/HDR (tone mapping) content, 1080p video, HD audio via pass-through (Atmos, DTSHDMA etc), Multichannel FLAC 24/192kHz etc. All via 1GBE LAN from NAS.

  • I concur with HomerJau on playing content with my 8th gen NUC. HEVC/HDR leverages Kodi tone mapping and plays fine. Eventually it will be pure HDR once the Intel drivers and other code updates occur. There's a separate thread on this topic you've been involved with.

  • HomerJau and jbinkley60,

    Any special configuration setting for that HDR (Kodi Tone Mapping)? I have a Sony 4K Projector for it and just wondering if I need to change some parameters on libreELEC for it.

    Please let me know.

  • LibreElec 9 with Kodi 18 currently does tone mapping HDR > SDR to show ‘correct looking’ colours on your screen. It does not output HDR. (Without tone mapping HDR 10 bit video looks washed out).

    There’s a thread in Hardware here where chewitt posted that true HDR output is being worked on now but won’t make the LibreElec 9.0 release, but will make LibreElec 10 release and will probably make a future LibreElec 9.x release. So our best scenario will see HDR added sometime this year (hopefully sooner than later, e.g. in LibreElec 9.1 - but it’s too early for anyone to know for sure)

  • We will wait then for the next releases. For now HDR playback on standalone players. Another question.. When I tried changing the resolution of Kodi Interface from 1080P to 3840x2160P I get a black screen and projector goes into the state as if nothing is connected to it. I need to hard reset the NUC to get it to display again in 1080P. Am I missing something? The refresh rate is set @ 60.

    Any ideas?

  • Below all resolutions it support. It s a Sony VPL-295ES Native 4K Projector:

    480/60p, 576/50p, 720/60p, 720/50p, 1080/60 i, 1080/50 i, 1 080/60p, 1080/50p, 1080/24p, 3840 x 216 0/24p, 3840 x 2160/25p, 3840 x 2160/30p, 3840 x 2160/50p, 3840 x 2160/60p, 4096 x 2160/24p, 4096 x 2160/25p, 4096 x 216 0/30p, 4096 x 2160/50p, 4096 x 2160/60p

    So not sure why when selecting 3840x2160p it goes dark and the display never comes back up until I do a hard reset of my 8th Generation NUC with LibreELEC 8.95.02.

  • Their webpage does say it is HDMI 2 compatible. How about setting the refresh rate to 30 and then try 3840x2160P. ? If that works then try 60 and see what happens. Also have you tried a different cable ? I've had cable issues in the past which impacted 4K playback.

  • embeleco : This problem is only when you set the Kodi UI to 4K right? If you leave the UI at 1080p But set whitelist 3840x2160 your NUC should playback in 4K with 4K content.